Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Shortcut on my Firefox homepage will not dismiss

  • 8 replies
  • 0 have this problem
  • 701 views
  • Last reply by loyall

more options

I want to dismiss one shortcut out of the two rows of shortcuts on my homepage. When I left click on the three dots on the Google Translate shortcut, and then left click on dismiss, the shortcut blinks and remains.

I want to dismiss one shortcut out of the two rows of shortcuts on my homepage. When I left click on the three dots on the Google Translate shortcut, and then left click on dismiss, the shortcut blinks and remains.

Chosen solution

Cor-el, I can now provide additional information. Today the unwanted shortcut reappeared because I went to that website again. This time I decided to take your advice and I selected Delete from History instead of Dismiss, but nothing happened. Clicking neither of the two choices resulted in the shortcut being deleted. I discovered, however, that if I first pinned the shortcut, then the Dismiss and Delete form History both worked to remove the shortcut. Perhaps my experience can help other Firefox users. You can mark this post as the answer to my question

Read this answer in context 👍 0

All Replies (8)

more options

Firefox doesn't have the google translator on it. So not sure what your referring to here since there is no screenshot to show others what your trying to do?

more options

Google Translate is irrelevant It is just an example of the shortcut I am tryin to dismiss. As I explained in detail, this shortcut on the Firefox homepage will not dismiss. Firefox's dismiss command does not seem to function.

more options

Your question is thoroughly confusing without any screenshots to show others what your trying to do there.

This is the closet I find talking about shortcuts in Firefox. Also Firefox has No HomePage it has a default install page only with standard default search engine install. The User has to create or set a homepage.

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page#:~:text=page%20is%20set.-,Set%20your%20home%20page%20through%20Firefox%20Settings,URLs%20or%20a%20blank%20page.

https://support.mozilla.org/en-US/kb/create-desktop-shortcut-website

Modified by Dropa

more options

I do not see how my question can cause confusion unless you are new to Firefox. Of course Firefox has a homepage. Mine is set to default. The homepage link is the house symbol on the top toolbar as shown on the attached screenshot. You can also see the two rows of Firefox hompage shortcuts along with the dropdown showing the dismiss command. The dismiss command as shown in the screenshot does not function to dismiss the example shortcut to the Mozilla Support Community. I hope this helps you understand my straightforward question.

more options

If you you do not need to keep history references to the Google Translate website then you can click Delete from History as this is better than using Dismiss. Dismiss adds the hashed website URI to the browser.newtabpage.blocked pref and this pref can become rather large if you dismiss a lot.

You can possibly pin pages to tiles to prevent Firefox from filling them with history items.

more options

Thank you Cor-el for taking my question seriously. I do not understand what you said about browser.newtabpage.blocked pref Fortunately it does not matter, because after repeatedly clicking pin then unpin and then dismiss the unwanted shortcut somehow finally disappeared. I am not sure what I did to make it disappear. In future I will take your suggestion to use Delete from history rather than using Dismiss. I appreciate your help.

more options

Changes made manually on the Firefox Home page are stored in prefs that you can find on the about:config page.

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

more options

Chosen Solution

Cor-el, I can now provide additional information. Today the unwanted shortcut reappeared because I went to that website again. This time I decided to take your advice and I selected Delete from History instead of Dismiss, but nothing happened. Clicking neither of the two choices resulted in the shortcut being deleted. I discovered, however, that if I first pinned the shortcut, then the Dismiss and Delete form History both worked to remove the shortcut. Perhaps my experience can help other Firefox users. You can mark this post as the answer to my question