Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 2FA will not accept 6-digit codes

  • 2 replies
  • 0 have this problem
  • 78 views
  • Last reply by HBound

more options

I have tried both Google Authenticator and Guardian for use with Mozilla 2FA. I have tried scanning the QR code on my PC multiple times on each authentication app and retrieving multiple codes each time, but all entries stated "incorrect 6 digit code" on my PC to enable 2FA. I am not sure how this is not working. Both authenticator apps identified my correct login email address associated with my Mozilla account so I know it must have something to do with whatever is happening on the back end at Mozilla for my account.

Also, I have read a few posts in the Mozilla support knowledgebase regarding this very same issue, but did not see any resolution. I would really like to have 2FA. Can someone please contact me about this?

I have tried both Google Authenticator and Guardian for use with Mozilla 2FA. I have tried scanning the QR code on my PC multiple times on each authentication app and retrieving multiple codes each time, but all entries stated "incorrect 6 digit code" on my PC to enable 2FA. I am not sure how this is not working. Both authenticator apps identified my correct login email address associated with my Mozilla account so I know it must have something to do with whatever is happening on the back end at Mozilla for my account. Also, I have read a few posts in the Mozilla support knowledgebase regarding this very same issue, but did not see any resolution. I would really like to have 2FA. Can someone please contact me about this?

Chosen solution

Just checking: are you sure that the clock is in sync on both devices? That's the usual culprit.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Just checking: are you sure that the clock is in sync on both devices? That's the usual culprit.

more options

That was it! For some reason my PC time was not checked to auto adjust. Once I did that everything worked! Thank you!