Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

103 update breaks video playback.

  • 1 reply
  • 0 have this problem
  • 5 views
  • Last reply by cor-el

more options

Both Youtube, gfy, reddit, or playing any mp4 in browser becomes erratic, sometimes it wants to work, sometimes it doesn't. Simple as explained.

Twice I did a w10 system restore back to v.102 and playback is normal. Twice i update to 103, and playback becomes botched. sometimes videos work, sometimes they don't, no loading, then sometimes background loading for minutes but no play, very random, very erratic.

So now i have 103 update blocked to avoid this problem.

Both Youtube, gfy, reddit, or playing any mp4 in browser becomes erratic, sometimes it wants to work, sometimes it doesn't. Simple as explained. Twice I did a w10 system restore back to v.102 and playback is normal. Twice i update to 103, and playback becomes botched. sometimes videos work, sometimes they don't, no loading, then sometimes background loading for minutes but no play, very random, very erratic. So now i have 103 update blocked to avoid this problem.

All Replies (1)

more options

See:


You can check for issues with Total Cookie Protection.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.