Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens in small window

  • 4 replies
  • 1 has this problem
  • 141 views
  • Last reply by cor-el

more options

A few days ago Firefox started opening in a small window in the upper left corner of the screen. This problem was earlier also posted by other users. So I have read all these topics and suggested solutions.

This is what I have tried: - removing xulstore.json - compatebility tab in properties - manipulating overlapping squares icon and dragging window to almost full screen - Reinstalling Firfox ( without removing Firefox completely on forehand)

So far nothing resolves this problem.

Please advise

A few days ago Firefox started opening in a small window in the upper left corner of the screen. This problem was earlier also posted by other users. So I have read all these topics and suggested solutions. This is what I have tried: - removing xulstore.json - compatebility tab in properties - manipulating overlapping squares icon and dragging window to almost full screen - Reinstalling Firfox ( without removing Firefox completely on forehand) So far nothing resolves this problem. Please advise

Chosen solution

Yes, that is one of the consequences of using "Resist Fingerprinting" mode. It also changes the user agent to the current ESR release (91) as you can see in the System Details.

Read this answer in context 👍 1

All Replies (4)

more options

What happens when you open the window, resize it to what you want, and then hold the crtl key and click on the X to close the window. When you open it again it should be same size as you closed it.

more options

Thanks for your advise jonzn4SUSE, However it does not solve the issue. This is exactly what happens:

When I start Firefox it opens in its normal full sized window. But within a split second it resises to a small window in the upper left corner. This happens every time when I open Firefox.

I have been using Firefox for years and this has never happened before until two days ago.

Kind regards Cornelis

more options

I think that I have found the cause of this behaviour. Two days ago I installed Cyberghost . Cyberghost Privacy gard has a setting under the tab Firefox, to let Firefox perform additional Finger Print protection. When I turned this setting off, Firefox opens in a normal window.

more options

Chosen Solution

Yes, that is one of the consequences of using "Resist Fingerprinting" mode. It also changes the user agent to the current ESR release (91) as you can see in the System Details.