Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

(Some) pages of several news outlets are not displayed properly

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by Zian

more options

Since a short while Firefox seems to stop displaying certain pages on news outlets like e.g. BBC, CNN or FAZ (German newspaper). When the link is clicked the page is displayed first for a short moment then the screen turns blank. On a refresh the page is shown again for a moment only to disappear again. It does not pertain to all pages on the sites, only to specific ones. Odd is too that sometimes third party adds are shown but not the main content of the page itself. It is also noteworthy that this is only happening with news related websites others seem to work normal. This is relatively new. I cannot pin it exactly on a certain time but just about less than 4 weeks ago that problem was not there. Could the issue be related to a recent Firefox update? Do I need to change something in the settings? I would be thankful for feedback. Thank you. JM

Since a short while Firefox seems to stop displaying certain pages on news outlets like e.g. BBC, CNN or FAZ (German newspaper). When the link is clicked the page is displayed first for a short moment then the screen turns blank. On a refresh the page is shown again for a moment only to disappear again. It does not pertain to all pages on the sites, only to specific ones. Odd is too that sometimes third party adds are shown but not the main content of the page itself. It is also noteworthy that this is only happening with news related websites others seem to work normal. This is relatively new. I cannot pin it exactly on a certain time but just about less than 4 weeks ago that problem was not there. Could the issue be related to a recent Firefox update? Do I need to change something in the settings? I would be thankful for feedback. Thank you. JM
Attached screenshots

All Replies (1)

more options

From the icon on the top right, it seems you have a content blocker (ad blocker) extension enabled. This can cause trouble with certain websites. To disable it, either: 1. Add the news website to the whitelist for your extension (click on the icon on the top right that looks like a ghost and there should be either a switch or an Add to whitelist button). 2. Or disable the ad blocker completely. Go to about:addons in your address bar and toggle extensions with "Ad block" or similar words in their names.

Some other steps you can take: 1. Disable Strict Tracking Prevention mode: Go to about:preferences#privacy and change the setting to Standard instead of Strict under Enhanced Tracking Prevention 2. Enable cookies for the website: about:preferences#privacy -> Cookies and Site Data -> Manage Exceptions. Add the news websites' url and choose Allow. 3. If all else fails, Open in Troubleshoot Mode. If this works, then you know a problem is with your settings/extensions.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.