Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot turn off HTTPS

more options

1 From Menu, I selected Settings

2 I then selected Privacy & Security
3 I Scroll down to HTTPS-Only Mode 
4 I selected Don't enable HTTPS-Only Mode

When I put in "http://docs.imsidesign.com/projects/TurboCAD-2021/turbocad-2021-user-guide-publication/Customized-Programming/Parametric-Part-Script-Editing/ the address bar always changes to https...

I've tried restarting Firefox, I tried restarting my computer. nothing I've done will turnoff HTTPS mode

The address works fine in MS Edge.

I have Windows 10 Pro version 20H2 on a Dell 7750 purchased in Apr/2021.

I use TurboCAD 2021 Platinum. I'd like to use the TurboCAD online help with Firefox.

I contribute monthly to Mozilla.

1 From Menu, I selected Settings 2 I then selected Privacy & Security 3 I Scroll down to HTTPS-Only Mode 4 I selected '''Don't enable HTTPS-Only Mode''' When I put in "http://docs.imsidesign.com/projects/TurboCAD-2021/turbocad-2021-user-guide-publication/Customized-Programming/Parametric-Part-Script-Editing/ the address bar always changes to https... I've tried restarting Firefox, I tried restarting my computer. nothing I've done will turnoff HTTPS mode The address works fine in MS Edge. I have Windows 10 Pro version 20H2 on a Dell 7750 purchased in Apr/2021. I use TurboCAD 2021 Platinum. I'd like to use the TurboCAD online help with Firefox. I contribute monthly to Mozilla.

Chosen solution

The DNS over HTTPS feature is a completely different setting: Firefox DNS-over-HTTPS.

Read this answer in context 👍 0

All Replies (16)

more options

Does it help if you enable HTTPS-Only mode and create an HTTPS-Only exception for "http://docs.imsidesign.com" ?

Helpful?

more options

Check out; Support Forum discussions https://support.mozilla.org/en-US/forums/support-forum-contributors/715468 User: Firefox only allows access if https-Only Mode is turned off ENTIRELY

Helpful?

more options

I tried adding "http://docs.imsidesign.com/projects/TurboCAD-2021/turbocad-2021-user-guide-publication/Customized-Programming/Parametric-Part-Script-Editing/" to the Manage Exemptions. It created "http://docs.imsidesign.com" in the list. I save the list. I then tried to go the address I entered but Cloudflare still intercepts the address, as it has "https..." in the address bar.

Do I need to uninstall Firefox?

Helpful?

more options

Try to use "Forget About This Site" to remove prossible secure HTTPS remnants (https://) to this origin.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

more options

I tried "Forget About This Site". I made sure it was removed from all of my history and bookmarks. When I put in "http://docs.imsidesign.com/" it still goes to "https://docs.imsidesign.com/"

Helpful?

more options

Are you using a private window to visit the site?

When I try the address in a private window, this appears in the Browser Console:

> HTTPS-First Mode: Upgrading insecure request “http://docs.imsidesign.com/” to use “https”.

This is something separate from the "HTTPS Only" feature, which you can manage in detail. Since Firefox 91, the "HTTPS First" feature is automatically enabled in private windows (Firefox 91 introduces HTTPS by Default in Private Browsing). That feature does NOT allow user exceptions.

You might need to disable "HTTPS First" and enable "HTTPS Only" in private windows to find the best balance of convenience and protection.

Disabling HTTPS First in private windows

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste dom.security.https_first_pbm and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

You can close this tab now.

Enabling HTTPS Only in private windows

You can set this up on the Settings page. See: HTTPS-Only Mode in Firefox.

Helpful?

more options

I filed a new bug report about that site. No need to add comments, and I wouldn't expect any quick changes because it's an odd situation.

https://bugzilla.mozilla.org/show_bug.cgi?id=1747673

Helpful?

more options

If network.trr.mode = 2 then I also get redirected to HTTPS and the website fails to load (521 error). With network.trr.mode = 0 it works.

Helpful?

more options

I'm NOT using a private window. I changed "dom.security.https_first_pbm" to false. That did not make any difference.

Helpful?

more options

RnDHenderson said

I'm NOT using a private window. I changed "dom.security.https_first_pbm" to false. That did not make any difference.

cor-el said

If network.trr.mode = 2 then I also get redirected to HTTPS and the website fails to load (521 error). With network.trr.mode = 0 it works.

Hmm, I could not replicate the problem in a regular window, only a private window with HTTPS First enabled in private windows. However, I was using local DNS.

If I enable DNS over HTTPS (cor-el mentioned the about:config method for that), then I also have the problem in a regular window.

That is difficult to understand, since the local DNS and Cloudflare DNS servers both seem to be returning the same address: [2606:4700:3033::ac43:8ba6]. Does enabling DNS over HTTPS also trigger some kind of "HTTPS First" behavior?

Helpful?

more options

I'd like to try uninstalling Firefox then reinstalling it. How do I save my bookmarks? Does uninstall leave any files? (Many programs leave something)

Thanks

Helpful?

more options

Historically, when you uninstalled, none of your data was removed. I think now the uninstaller might ask whether you want to remove your data or keep it. It also may offer the Refresh option. More on that: Refresh Firefox - reset add-ons and settings.

HOWEVER, why do you think uninstalling and reinstalling would give you different results? Did you already try turning off DNS over HTTPS? Firefox DNS-over-HTTPS.

Helpful?

more options

I uninstalled and reinstalled Firefox. It still goes to HTTPS even though Don't enable HTTPS only mode is selected.

Helpful?

more options

Chosen Solution

The DNS over HTTPS feature is a completely different setting: Firefox DNS-over-HTTPS.

Helpful?

more options

THANK YOU!!!. for the link. That explained what I needed to know. I followed the instructions and now I can access the domain in Firefox.

Thanks Again, Rich Henderson

Helpful?

more options

I was able to go back and "Enable HTTPS-Only Mode in all windows" then enter "http://docs.imsidesign.com/" in the "Manage Exceptions" window.

Thanks again Rich Henderson

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.