Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

microsoft stream please help

  • 8 replies
  • 1 has this problem
  • 88 views
  • Last reply by Kiki

more options

Microsoft stream doesn't work (specifically watching a video) , i tried reloading a bunch of times but it still wouldn't work. I went on my phone to the firefox browser and tried to watch that stream on there, but that didn't work either. Please help and thank you. Uploaded photo is what it looked like on my phone

Microsoft stream doesn't work (specifically watching a video) , i tried reloading a bunch of times but it still wouldn't work. I went on my phone to the firefox browser and tried to watch that stream on there, but that didn't work either. Please help and thank you. Uploaded photo is what it looked like on my phone

Modified by jkhsiouery80pewohn

Chosen solution

Hi jkhsiouery80pewohn,

We just release Firefox 95.0.1 that should fix this issue. Can you update your Firefox and confirm if your issue is fixed?

In addition to that, please note that changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. Now that we have the fix, it's best to undo the pref change you've made above.

Please read Firefox advanced customization and configuration options to learn more.

Read this answer in context 👍 0

All Replies (8)

more options

This is what it looked like on my phone

Modified by jkhsiouery80pewohn

more options

Show us what it looks like on your desktop. I cannot access Microsoft Stream without a business account so there is no way for me to replicate the issue.

more options

This is what it looks like but no matter how much i try reloading, it doesnt work. It works on other browsers , I have no idea why it doesn't on firefox

Modified by jkhsiouery80pewohn

more options

Try to enter about:config in the URL bar and set security.ssl.enable_ocsp_stapling = false.

more options

Thank you so much TyDraniu!!!!

more options

Chosen Solution

Hi jkhsiouery80pewohn,

We just release Firefox 95.0.1 that should fix this issue. Can you update your Firefox and confirm if your issue is fixed?

In addition to that, please note that changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. Now that we have the fix, it's best to undo the pref change you've made above.

Please read Firefox advanced customization and configuration options to learn more.

more options

kiki, i've updated my firefox, yeah without the "security.ssl.enable_ocsp_stapling = false." (changed it back to true) and it works

more options

Good to hear. Happy surfing!