Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Streaming video

more options

Last night it worked fine but today I went onto Amazon Prime to watch movies or programs and it wouldn't play. It says I need the newest version of firefox to be able to watch. I have it already but no go.

All Replies (7)

more options

Let me boot to Win7...

Helpful?

more options

Can you post a screenshot showing the issue? A full browser and not just the error message. Something is going on with my Win 7 and this image server that makes my images black and white.

Helpful?

more options

Your User Agent shows: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0/7KqG0NfZ-56

Note the junk at the end.


https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/


Do you have enabled "Resist Fingerprinting" if you check ‘’’Resist Fingerprinting’’’ on the ‘’’about:config’’’ page as this affects the user agent?


’’’Avast AntiTrack’’’ is also known to cause this issue.

Helpful?

more options

There's nothing more on that page really. It was just about ready to start and then the message appeared. Sometimes it will do it before it gets that far.

Helpful?

more options

Can you reply to Fred's comment?

Helpful?

more options

The junk at the end I know nothing about or how it got there. What does it mean? It now doesn't matter. My system upgraded yesterday to the newest 95 so everything is back to normal.

Helpful?

more options

I would try cleaning my cache and clean cookies for amazon prime's website.

  1. Type "about:preferences#privacy" into your search bar.
  2. Scroll down to "Cookies and Site Data"
  3. Click "Manage data" and search for the website domain name.
  4. Highlight the correct result, click "Remove selected" then press "Save Changes".
  5. Try the video playback again.
  • If that doesn't work, try looking into your extensions, maybe something is blocking it. This could especially happen on adblockers since they usually have blacklist updates, it could be a false positive in this case.
  • If that doesn't work either you might wanna try resetting your browser or fully reinstalling it.

Hope it this helps :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.