Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox v90 very slow loading AOL email site

  • 7 replies
  • 1 has this problem
  • 43 views
  • Last reply by FredMcD

more options

I've been using site https://mail.aol.com/webmail-std/en-us/suite for years to log in to AOL email for years and now, with Firefox v90, it takes over 2 minutes to load. It takes only a couple seconds with the Edge browser. I've tried troubleshooting mode, a refresh and a complete re-installation without any improvement. This never happened in previous versions of Firefox.

Any help is appreciated, Gary S.

Chosen solution

The new version 90.0.2 has solved my problem!! Thank you, Fred and the Firefox team for the quick response! Now that's customer service !!

Read this answer in context 👍 0

All Replies (7)

more options

I had no issue with the link.

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

I already tried troubleshooting mode as well as the other things mentioned in my original report. I also cleared cookies and history with no change. When you said you had no issue with the link, did you actually supply a username and password and log into AOL? The slowness doesn't happen until after you've entered your password and pressed ENTER. Then I see little messages appear in the lower left pf the screen starting with "Transferring data from a.aolcdn.com" and then "Connecting to csp.yahoo.com. A lot of time lapses during both these operations with the latter one being the slowest. I see none of these messages when using MS EDGE, only "Connecting .. " and it's there about a second before loading completes.

Hope this helps.

Helpful?

more options

gvmbear said

. . . did you actually supply a username and password and log into AOL?

I don't have an account there.

The slowness doesn't happen until after you've entered your password . . .

You did not say that.

Delete browsing, search and download history on Firefox {weblink}

Remove a single website from your history {weblink}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

Helpful?

more options

Sorry- I should have been clearer about the logging in part. I went to the history manager, typed in the site (https://mail.aol.com/webmail-std/en-us/suite) and pressed ENTER. Nothing appeared in the listings box below and it displayed "No items." I've cleared pretty much everything that can be cleared,b but it makes no difference. It continues to perform the operations I described in the previous message and bogs down there. I would have thought maybe AOL was the cause, only this doesn't happen in the EDGE browser and I've never seen this before I updated to version 90.

Any other ideas?

Helpful?

more options

I called for more help.

Helpful?

more options

Chosen Solution

The new version 90.0.2 has solved my problem!! Thank you, Fred and the Firefox team for the quick response! Now that's customer service !!

Modified by gvmbear

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.