Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bold font on web forma, log ins, pdfs

  • 6 replies
  • 1 has this problem
  • 22 views
  • Last reply by cfillion2

more options

Since the most recent update to 89.0 opening pdfs in the browser, some websites and all log-in areas are using a super bold, unreadable font. PDFs also print out with this font. I tried changing the font manually, and both checking and unchecking the "Allow pages to choose their own fonts, instead of your selections above" box, but it doesn't help. I have no plugins installled This is the Facebook log in for example. The font is so poor you can't tell the 'i' from a lower case 'l'. The pdf sample is from opening it in the browser. If I download it instead, it opens in a normal, readable font. How can I fix this?

Attached screenshots

Chosen solution

You can try to set gfx.e10s.font-list.shared = false on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Read this answer in context 👍 1

All Replies (6)

more options

This could be a problem with the font that is used and in this case a bolder font is being used.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

I don't understand how this is a solution? I can get to the page inspector and the font editor (see screencap) and I can see that it's Helvetica Black- and it will change the font size and the spacing, and the 'italics' button works, but 1) changing the weight doesn't change anything, and 2) as soon as I refresh or leave the page, it reverts to the original settings. I don't understand why this is only happening with Firefox. Things look normal in Chrome:

Compare this to the image above with Firefox.

If there is something in the Inspector that I can change permanently, I would need more detailed instruction, please.

Helpful?

more options

Do you need the Helvetica fonts as this isn't the first time that issues with Helvetica fonts are reported on Windows ?

What fonts are specified on these pages if you check the font-family rule in the rules tab ?

Helpful?

more options

Font family:

This is on the FB login page. But on the pdf that also gives me bold face type it is Arial. The thing is nothing else changed on my system except this 'upgrade' of Firefox 89.0, so being a Windows problem with Helvetica doesn't seem reasonable.

Helpful?

more options

Chosen Solution

You can try to set gfx.e10s.font-list.shared = false on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

more options

"You can try to set gfx.e10s.font-list.shared = false on the about:config page."

This worked, thank you.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.