Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox very slow starting up and one more issue...

  • 4 replies
  • 1 has this problem
  • 20 views
  • Last reply by fidservant

more options

I had tried everything. I have deactivated all FOUR of my plugins and started up Firefox again. I have uninstalled and reinstalled a fresh copy. I installed Firefox on an SSD even and it is still painfully slow. I have the same plugins and such on Chrome and that one opens up immediately. So I have been using Chrome a lot more lately because Firefox is opening slowly these days. Takes 15-20 seconds for Firefox to open every single time. I have deactivated each plugin one by one to see if they were causing the issue and sure enough, all of them were clean. Firefox still opens slowly.

On an unrelated note, I have been using Chrome a lot more lately also because some things on a webpage don't work on Firefox. I can't explain it. Like on the hickory farms website, I click on the Add To Cart button and it looks like it is being pressed, but nothing is added to the cart. This type of thing happens across the internet on many different sites. When I go to Chrome, everything works as it ought to. I have my settings set to Standard in Privacy and Security. I don't know where else I have to check and change things to get those buttons and other links and such to work.

All Replies (4)

more options

Helpful?

more options

No it doesn't. It's still slow loading.

Helpful?

more options

Still there? I searched the web and I have found that others are experiencing the same issue of Firefox being slow after version 88 the same as me. So at least I know it is not an isolated issue. Can anyone out there help me? It's ridiculously slow. I clicked on Firefox first then Chrome and Chrome opened in less than a second and Firefox was still taking its sweet time to load. I was already browsing and reading a webpage on Chrome when Firefox finally opened. I did the same test with Brave and that even opened quickly. I think I have more add-ons and plugins on both those browsers than I do on Firefox. And I turned off all my plugins on Firefox and experienced the same issue. VERY slow loading. Takes more than 10 seconds to open. Feels like I am running my machine on a Windows 95 computer. Maybe Mozilla will fix this for a version 90 release? Who knows...

Also, I tried some of the support suggestions like about:support and discovered that the support suggestions on Firefox are seriously out of date. The support recommendation it offered I was unable to complete because there was no folder or file that the support page stated I needed to alter, change or delete.

Modified by Dyrelogan

Helpful?

more options

YA KNOW...all the "support work-arounds" offered would be much more helpful if I had a giant, wall-sized screen and could open two FULL windows at a time. Following complex instructions just is not cutting it.

When I go to FF Help now, it gives me a Mozilla page requiring log-ons I either don't have or will not use. Log in with Facebook? Do you think I'm stupid?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.