Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Streaming websites with Firefox 85

  • 6 replies
  • 1 has this problem
  • 27 views
  • Last reply by FredMcD

more options

Ever since Firefox updated to version 85, I have been unable to stream anything. Netflix tells me I need to install Microsoft's Media Feature pack. Nope! I am running Windows 7 Home Premium (NOT the "N" version) so I have Windows Media Player installed already. I also cannot stream SiriusXM stations, Apple TV+, Spotify, CNN videos.....basically anything that involves streaming. YouTube videos still work however.

It's definitely a problem with the Firefox browser because all the above streaming sites work just fine under a different browser (Chrome). I have cleared the cache, I have started Firefox in Safe Mode, I have unchecked hardware acceleration.....NOTHING works!

Help please! I really don't want to refresh Firefox and lose all my settings.

Chosen solution

Hey FredMcD, thanks so much for all your help!! I've been wracking my brain over this for a couple of days....finally decided to try running "sfc /scannow" in a cmd window. It worked!! I guess I had a corrupt windows system file that was causing all the problems.

Read this answer in context 👍 0

All Replies (6)

more options

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version?

Version 85.0.1, first offered to Release channel users on February 5, 2021


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

I've done absolutely all those suggestions! I'm running the latest version of Firefox. I deleted cookies, cleared cache. I started Firefox in Safe Mode. I disabled all my add-ins, including any adblockers (uBlock Origin and Ghostery). This issue just started with Firefox 85. Could it have something to do with Adobe Flash, although not likely as everything works just fine in Chrome. I'm very puzzled!

Helpful?

more options

Jane said

Netflix tells me I need to install Microsoft's Media Feature pack. Nope! I am running Windows 7 Home Premium (NOT the "N" version) so I have Windows Media Player installed already.

Try installling it anyway: https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

Helpful?

more options

Yeah I tried that too. Unfortunately since I am still running Windows 7, Microsoft no longer supports that and on the link that you provided, they tell me "the download is no longer available". After googling, I managed to find the file somewhere else and downloaded it. Went to run it and was told "Update is not applicable to your PC"! Grrrrrr.....

I also tried uninstalling and reinstalling Windows Media Player...that did nothing and I really don't think it's the issue because it works fine elsewhere.

I suppose one option might be to upgrade Windows however, my PC is over 10 years old (still runs perfectly) but I think switching to Windows 10 now would cause me all kinds of unnecessary grief with old drivers, etc. Plus I don't think it's a Windows problem anyway.

I really like Firefox but it looks like I may have to switch to Chrome where everything works.

Helpful?

more options

Chosen Solution

Hey FredMcD, thanks so much for all your help!! I've been wracking my brain over this for a couple of days....finally decided to try running "sfc /scannow" in a cmd window. It worked!! I guess I had a corrupt windows system file that was causing all the problems.

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.