Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox slows or even freezes when typing text

  • 3 replies
  • 1 has this problem
  • 248 views
  • Last reply by FredMcD

more options

Firefox slows down or even freezes for a longer time when I am typing in text in forms (like new GMAIL messages, search boxes, etc). Especially when I make mistakes and delete some.

I have Refreshed Firefox and removed the Adblocker add-on, which I thought might cause the problem, but the problem persists.

Any idea how to tackle this?

Firefox slows down or even freezes for a longer time when I am typing in text in forms (like new GMAIL messages, search boxes, etc). Especially when I make mistakes and delete some. I have Refreshed Firefox and removed the Adblocker add-on, which I thought might cause the problem, but the problem persists. Any idea how to tackle this?

Chosen solution

Dear Fred and others,

I have found the reason for the slow-down and it is related to Windows 10 and Firefox. There is a possibility within Windows 10 to highlight your text cursor with a blue hue above and under it, so you can find it back more easily.

The problem of text freezing appears when this is switched on.

I have no idea which interactions play a role here, but after I switched this possibility off, I had no further problems with the freezing.

Read this answer in context 👍 0

All Replies (3)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Chosen Solution

Dear Fred and others,

I have found the reason for the slow-down and it is related to Windows 10 and Firefox. There is a possibility within Windows 10 to highlight your text cursor with a blue hue above and under it, so you can find it back more easily.

The problem of text freezing appears when this is switched on.

I have no idea which interactions play a role here, but after I switched this possibility off, I had no further problems with the freezing.

more options

That was very good work. Well Done.