Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox opens off screen

  • 8 replies
  • 1 has this problem
  • Last reply by David400

more options

On new laptop with Windows 10, with an external monitor in extended desktop mode, Firefox is opening partially off screen such that the top bar is inaccessible so I cannot drag it back on screen. If I close it and reopen, it will usually be back on screen. How can I fix this?

Perhaps related: tabs are not reopened and Restore Previous Session does not work.

There are no extensions open.

Thank you for assistance.

Chosen solution

Is the resolution of both your laptop and external monitors the same? In your display section of Windows 10 settings, check the resolutions of both monitors and adjust accordingly.

Read this answer in context 👍 0

All Replies (8)

more options You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

more options

Thanks Fred. Renaming Xulstore didn't work, but I got a partial solution through the second suggestion on the link you included: refresh. It still sometimes opens off screen, but not always. Sometimes it opens correctly on the laptop screen (vs the external monitor, but that doesn't matter). When I open a second window, that seems to work along with the previous session windows.

Oddly, I can't close that first window. The "X" isn't visible and right clicking it in the taskbar and selecting close doesn't work. I have to go through Ctrl-Alt-Del, which of course closes all Firefox windows.

Some of this may be due to using an extended monitor, but that didn't happen in my previous laptop and monitor. The resolutions in the new ones are different from the old, so that may be a factor, but still it shouldn't do this.

more options

Additional: I CAN close that first window. I hadn't answered the "do you want to make Firefox the default browser," which fortunately was in the part of the window that was not off screen.

more options

I'm still experiencing this problem and am wondering if you have any other suggestions.


more options

Chosen Solution

Is the resolution of both your laptop and external monitors the same? In your display section of Windows 10 settings, check the resolutions of both monitors and adjust accordingly.

more options

Hi Colin, No, they're not the same and I agree that is most likely the cause of the issue. Both the laptop and the external monitor are in their recommended resolutions: 3480 x 2160 and 1920 x 1080 respectively. (It's lovely that the laptop has such a high res screen.) I was resisting stepping down the laptop res, but that does seem to fix several things while, of course, creating some other problems. I may have to see if I can live with that for a while. Thanks, David

more options

Hello David,

I have some new alternatives for you to try. Select the firefox program on the task bar and since you are on Windows you should be able to hold down the windows key and press the left or right arrow keys to move the window back into view. Another possible solution would be to hold down "SHIFT" and right click the firefox icon on the task bar. Then click the MOVE option. This will allow you to use the mouse or arrow keys to move the window back onto the active screen.

more options

Thanks Justin. I think changing the laptop screen resolution, though not ideal, seems to have solved the issue.