Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Issues with youtube

  • 15 replies
  • 8 have this problem
  • 624 views
  • Last reply by jonzn4SUSE

more options

Having an issue with youtube as of late on firefox. The ability to see "history" list, "watch later" list, or utilizing the save function do not work because I am constantly having to login. For some reason the ability to see lists or to utilize any functions on the youtube website do not work properly because I am unable to remain logged in. Is anyone else having difficulty with youtube?

Chosen solution

I reinstalled Firefox 84.0. The problem never solved. Pressing F12 Console shows a lot of warnings on cookie side with the message "Cookie “SIDCC” will be soon rejected because it has the “SameSite” attribute set to “None” or an invalid value, without the “secure” attribute. To know more about the “SameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite" 9 times with different cookie.

This problem is only on Windows 10. I think 80% of this problem is because of the Antivirus. I use Kaspersky Internet Security. It uses its own certificate to intercept HTTPS and HTTP requests and response. Firefox says that the certificate is not recognized but it is secure and trusted third-party. After shutdown the antivirus, I can login back to YouTube.

Read this answer in context 👍 3

All Replies (15)

more options

This is a common issue here in forum. I still have this issue on Win10 running 83.0, but on Win 7 running the beta 84.# it works fine now. I guess I'll install the beta on this Win 10 laptop and see what happens.

more options

Just installed the beta and it works. I can even comment now in Win 10!  ;-))

more options

Yeah Chris,

Give the beta a try and see what happens.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

@ jonzn4SUSE, appreciate all your help. I'll give this a try. Thanks!

more options

Gave it a shot and unfortunately it didn't work. Tried the beta, then tired a refresh on the beta. Both were unsuccessful in solving the problem. Then uninstalled and re-installed. No luck. The amazing thing is that these issues persists on both of my computers. Both are running Win 10. Each has firefox that is linked to my mozilla account. No issues with youtube on either computer using MS Edge browser.

more options

This issue can be caused by corrupted cookies or blocked cookies.


Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Tried each of the steps and issue was not solved. Problem persisted with Firefox in Safe Mode which is really interesting. Is it possible this is an issue YouTube?

Modified by Chris

more options

Chosen Solution

I reinstalled Firefox 84.0. The problem never solved. Pressing F12 Console shows a lot of warnings on cookie side with the message "Cookie “SIDCC” will be soon rejected because it has the “SameSite” attribute set to “None” or an invalid value, without the “secure” attribute. To know more about the “SameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite" 9 times with different cookie.

This problem is only on Windows 10. I think 80% of this problem is because of the Antivirus. I use Kaspersky Internet Security. It uses its own certificate to intercept HTTPS and HTTP requests and response. Firefox says that the certificate is not recognized but it is secure and trusted third-party. After shutdown the antivirus, I can login back to YouTube.

more options

AlkindiX said

I reinstalled Firefox 84.0. The problem never solved. Pressing F12 Console shows a lot of warnings on cookie side with the message "Cookie “SIDCC” will be soon rejected because it has the “SameSite” attribute set to “None” or an invalid value, without the “secure” attribute. To know more about the “SameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite" 9 times with different cookie. This problem is only on Windows 10. I think 80% of this problem is because of the Antivirus. I use Kaspersky Internet Security. It uses its own certificate to intercept HTTPS and HTTP requests and response. Firefox says that the certificate is not recognized but it is secure and trusted third-party. After shutdown the antivirus, I can login back to YouTube.

I have to thank you for your hint! Never thought about disabling kaspersky. after i closed it and restarted FF, youtube is now functional again.

more options

@ AlkindiX. This worked! I appreciate your help!

more options

I am using Kaspersky also in Windows. Will have also go see if stopping it fixes my issue in Windows.

more options

Just verified in Win 7, with Kaspersky off I can comment on YouTube. Turn it back on and I see the issue. Let me go check Win10.

Modified by jonzn4SUSE

more options

While the fact that the anti-virus is the problem here is useful, the fix being "Turn off your antivirus" is not. It would be useful to have a means of fixing this without removing my internet securities please.

more options

Hi bobbobert_010

You will have to contact Kaspersky for support if you have a problem with their software.

more options

bobbobert_010 said

While the fact that the anti-virus is the problem here is useful, the fix being "Turn off your antivirus" is not. It would be useful to have a means of fixing this without removing my internet securities please.

Kaspersky is aware of the issue, you have to update the software and also see below. I had to turn off a few setting in Kaspersky in order to fix the lag in typing,

https://community.kaspersky.com/kaspersky-security-cloud-11/kaspersky-cloud-free-laggin-my-text-input-in-firefox-and-chrome-software-version-is-21-2-16-590-14119?postid=65312#post65312