Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extensions not visible when never remember history selected

  • 5 replies
  • 1 has this problem
  • 27 views
  • Last reply by damon33

more options

Hi, I am using Firefox 83.0 64 bit (not sure if it has recently updated or not). I noticed today that my extensions were no longer visible in the top right corner, even though they were still installed. I tried to fix the problem by deleting/re-installing firefox several times but this did not seem to help. I have now found out that they disappear when I select "Never remember history" on the privacy page. They re-appear if I select Rember history from the drop down menu. Is this a bug or is there a way to fix this. Thanks

Modified by damon33

Chosen solution

If you select Never Remember History then you automatically enter PB mode as you can see if you select the custom setting. Choosing the custom setting doesn't make changes, but allows to inspect the current settings. You only (always) see the custom setting selected if there have been changes made to other history settings. "Never Remember History" and "Remember History" determine whether PB is active or not active.

Read this answer in context 👍 1

All Replies (5)

more options

Deleted

Modified by damon33

Helpful?

more options

Not all extensions work by default in Private Browsing mode, see:

Helpful?

more options

Thanks for your reply but I am not using private browsing mode, just choosing Never remember history from the privacy and security tab in options. Also they have always worked (been visible) until a few days ago.

Helpful?

more options

Chosen Solution

If you select Never Remember History then you automatically enter PB mode as you can see if you select the custom setting. Choosing the custom setting doesn't make changes, but allows to inspect the current settings. You only (always) see the custom setting selected if there have been changes made to other history settings. "Never Remember History" and "Remember History" determine whether PB is active or not active.

Helpful?

more options

You are completely right. I have now enabled them to run in private mode and they have re-appeared. I must havee had custom settings before. Thank you for your help

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.