Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook says I am using an unsupported browser

  • 3 replies
  • 1 has this problem
  • 24 views
  • Last reply by Don

more options

When I connect from Ubuntu 20 (LTS) this message shows and it redirects me to the mobile version. That's not all bad but the mobile version doesn't work as well as it does in the Android version of Firefox Beta.

Attached screenshots

Chosen solution

In another thread, someone mentioned this as a possible side effect of the FB Purity extension.

Read this answer in context 👍 1

All Replies (3)

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Helpful?

more options

Chosen Solution

In another thread, someone mentioned this as a possible side effect of the FB Purity extension.

Helpful?

more options

Both replies helped me find the problem. I'm pretty sure it's a combination of YesScript2 AND FBPurity but at any rate, it's not Firefox that Facebook hates, just things that interfere with its chosen JavaScript functions.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.