Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot log into chase.com using Firefox

  • 4 replies
  • 1 has this problem
  • 62 views
  • Last reply by cor-el

more options

I have not been able to log into chase.com using Firefox for about 3 days - previously it was fine. I CAN log into chase.com using Edge and Chrome. I CAN log into all other web sites I routinely visit using Firefox. Only problem is chase.com, and only in Firefox. I have read about similar problems and solutions in this forum and tried the cures - I have cleared cookies on chase.com by clicking on the "padlock" in the address line - I have cleared the cache - and I have disabled the hardware accelerator - still unable to log in. When I enter my user name and password on chase.com and click on "sign in", a completely white screen is returned with a 2 inch solid blue bar roughly in the middle of the screen. Help?

All Replies (4)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

more options

You appear to be using Kaspersky Total Security software and Kaspersky software has been mentioned fors causing this issue with the Chase website.

See this reply:

more options

I had this identical problem about a month ago - at that time the problem was CLEARLY caused by my Kaspersky security software. I contacted them at that time - they figured it out and gave me a "fix" to their software - and it completely solved the problem at that time. Problem then reoccurred a few days ago - FIRST thing I did was completely disable Kaspersky protections and try logging into Chase.com again - this time the problem did NOT go away. I went so far as to disable Kaspersky, close Firefox, restate the computer, open Firefox in "safe" mode and try logging into chase.com again - problem continues to persist. So I'm thinking the problem probably is not Kaspersky this time - trouble is, I still don't know what's causing it.

more options

It is usually quite hard to disable security software and some components may still be active and run in the background.

Did you try to boot the computer in Windows Safe Mode with network support ?