Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not showing images on some sites

more options

I suddenly have a problem with Firefox NOT showing certain images (linked ones I think) on various websites. It's not across the board, just about a dozen or so websites.

I briefly got some kind of Webp message that quickly blinked off before I could see what it said. I'm including two screenshots to show the problem I'm having.

Attached screenshots

Chosen solution

A friend of mine sorted it out for me!

Apparently "image.webp.enabled" somehow got toggled off so it's value was false. That might have been what that weird Webp quick blip of a message was about, though it went out before I could read anything on it.

Anyway, my friend set it back to true and now things work fine again.

Thanx anyway for all the offered help. It was greatly appreciated.

Read this answer in context 👍 0

All Replies (4)

more options

Try disabling Enhanced Tracking Protection (ETP). ETP is a collection of Firefox features that protect your privacy while you browse. See Enhanced Tracking Protection in Firefox for desktop for details.

Helpful?

more options

Regrettably that didn't change anything.

Helpful?

more options

Hello Black Knyght,

Thanks for reporting back.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu , click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.


Also, have you tried clearing your cache and cookies?

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Helpful?

more options

Chosen Solution

A friend of mine sorted it out for me!

Apparently "image.webp.enabled" somehow got toggled off so it's value was false. That might have been what that weird Webp quick blip of a message was about, though it went out before I could read anything on it.

Anyway, my friend set it back to true and now things work fine again.

Thanx anyway for all the offered help. It was greatly appreciated.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.