Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New tabs ALWAYS open to the right of the last open tab, not to the right of current tab

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by cor-el

more options

Hi --

As of the latest version of Firefox (v78.0.2 x64), all new tabs open at the end of the list of current tabs. If I only had a few tabs open, that MIGHT be okay, but since I keep many open, it's incredibly annoying. All I want is to open a new tab and have it appear to the right of the current tab. So far...

  • I've tried setting "browser.tabs.insertAfterCurrent" to true, with no effect.
  • I've tried the add-on "Always Right", with no effect.

Since I've noticed this behavior in many previous versions of FF, I doubt that uninstall/reinstall will address the problem, so I didn't try.

Any ideas?

Thanks in advance to all!

Dave

Chosen solution

There are two browser.tabs.insert prefs present on the about:config page.

  • browser.tabs.insertAfterCurrent = true
  • browser.tabs.insertRelatedAfterCurrent = true

The former is about opening a new tab via the '+' button on the tab bar.
The latter is about opening a link in a new tab.

If these prefs aren't working the n there might be a problem with an extension.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

There are two browser.tabs.insert prefs present on the about:config page.

  • browser.tabs.insertAfterCurrent = true
  • browser.tabs.insertRelatedAfterCurrent = true

The former is about opening a new tab via the '+' button on the tab bar.
The latter is about opening a link in a new tab.

If these prefs aren't working the n there might be a problem with an extension.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.