Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can you somehow (permanently) hide the "mobile bookmarks" folder on PC?

  • 9 replies
  • 1 has this problem
  • 25 views
  • Last reply by cor-el

more options

I did some searching and found out how to do in the config but that doesnt last for more than one restart

Chosen solution

maxklingler2 said

I got the url bar comand to work, but the mobile bookmaks still wont disapear.

Wesley provided rules for the menus: classic Bookmarks menu on the top menu bar and the optional Bookmarks Menu toolbar button menu. Maybe you are looking at the Bookmarks Sidebar or the Library window instead? Those are a lot harder to style.

... isnt theire a way with the css file to make browser.bookmarks.showMobileBookmarks = false by default? cause that works for me albeit only until I restart the programm

Not with CSS, but you could try locking that preference to false using an autoconfig file. More info on how that is set up:

Read this answer in context 👍 1

All Replies (9)

more options

To the best of my knowledge, there's no configuration option to remove that folder. You would need to remove it using a custom userChrome.css file with the following code:

#BMB_mobileBookmarks,
#menu_mobileBookmarks {
    display: none !important;
}

For more information on how to create a userChrome.css file, see the How to Create a userChrome.css File page on userchrome.org.

Hope this helps.

Helpful?

more options

I think I applied the config changes and made the right files in the right places, but on restarting nothing's changed. Might that have to do something with the language settings of my browser? I keep it in german as to keep it acessible to my family members. Is theire a way I can check if I at least did the userChrome.css file right?

Helpful?

more options

Hi maxklingler2, your user interface language should not affect rules that are based on id's or classes (selectors that start with # or .). Those are the same across all languages.

Three common reasons for completely non-working userChrome.css files are:

  1. You still need to go into about:config to tell Firefox to look for the file at startup (toolkit.legacyUserProfileCustomizations.stylesheets => true)
     
  2. Windows added .txt to the file name, so instead of being exactly userChrome.css it is really userChrome.css.txt (it's a good idea to set Windows to show all file extensions while doing these operations)
     
  3. The chrome folder is not in your currently active profile folder, for example, it is up a level in the Profiles folder or somewhere else

Sometimes users are using a program to edit the file that inserts formatting code or otherwise makes the file incomprehensible to Firefox. The Windows Notepad should be safe. Usually. Except for #2 above.

Is theire a way I can check if I at least did the userChrome.css file right?

If you open it in Windows' Notepad program, it should contain just the code Wesley listed.

Or did you mean you wanted to try another rule that would be very obvious as to whether Firefox is reading the file?

Helpful?

more options

The issue is probably with the toolkit.legacyUserProfileCustomizations.stylesheets preference. By default, custom stylesheets are disabled. You need to enable it in the about:config page on Firefox by setting it to true.

If you want to make sure that Firefox is reading the userChrome.css file properly, add this code to the file:

#urlbar {
    display: none !important;
}

That will hide the Firefox address bar. It will make Firefox difficult to use, but it's a good way to check that Firefox is reading the file correctly. Once you've verified that Firefox is reading the file, you can remove that code from the file.

NOTE: You need to restart Firefox after every change to the userChrome.css file in order for the changes to be applied.

Helpful?

more options

I got the url bar comand to work, but the mobile bookmaks still wont disapear. I am talking out of my ass here but isnt theire a way with the css file to make browser.bookmarks.showMobileBookmarks = false by default? cause that works for me albeit only until I restart the programm

Helpful?

more options

Chosen Solution

maxklingler2 said

I got the url bar comand to work, but the mobile bookmaks still wont disapear.

Wesley provided rules for the menus: classic Bookmarks menu on the top menu bar and the optional Bookmarks Menu toolbar button menu. Maybe you are looking at the Bookmarks Sidebar or the Library window instead? Those are a lot harder to style.

... isnt theire a way with the css file to make browser.bookmarks.showMobileBookmarks = false by default? cause that works for me albeit only until I restart the programm

Not with CSS, but you could try locking that preference to false using an autoconfig file. More info on how that is set up:

Helpful?

more options

That would be this code in autoconfig.cfg

// first line in autoconfig.cfg is a comment
lockPref("browser.bookmarks.showMobileBookmarks", false);

Note that this pref is automatically set by Sync if you successfully sync bookmarks from a mobile device.

Modified by cor-el

Helpful?

more options

Yes, I was talking about the sidebar indeed xD pretty never used something else so I wasnt even aware that we could be talking bout something else. Will try the autcofig later. edit: It worked^^ thanks for the help. shame I couldnt pin both messages for people who have the same question in the future.

Modified by maxklingler2

Helpful?

more options

It isn't possible to hide specific content in the sidebar via userChrome.css or otherwise because that is a treechildren type of list where you can't select individual items.

I've tested the lockPref() call in autoconfig.cfg and it hides the Mobile Bookmarks section in the sidebar and in the Bookmarks Menu and in other places.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.