Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using Windows Live Mail for "Email Link" no longer works

  • 4 replies
  • 1 has this problem
  • 28 views
  • Last reply by tootill

more options

I'm on Windows 10 but still use Windows Live Mail. I used to be able to click the "Email Link" icon on my Firefox toolbar to automatically mail the current URL to someone using Live Mail. I can go into Options>Applications>mailto and link it to xlmail.exe but I can't add the argument "/mailurl:%" to the end of the command line so that it properly constructs an email message. This used to work - does anybody have a suggestion (other than finally abandoning Live Mail or Firefox)?

Thanks.

Chosen solution

Thanks jscher2000 - I almost used the form he linked to. Also I solved the problem I was having; it was not a Firefox problem but just a Windows setting that I didn't realize had gotten reset back to default. All is well now - thanks!

Read this answer in context 👍 0

All Replies (4)

more options

Hi tootill, please ignore the unofficial support solicitation that someone posted. We have no idea where that leads and don't want you to get scammed.

Helpful?

more options

Chosen Solution

Thanks jscher2000 - I almost used the form he linked to. Also I solved the problem I was having; it was not a Firefox problem but just a Windows setting that I didn't realize had gotten reset back to default. All is well now - thanks!

Helpful?

more options

@tootill what windows setting did you change?

Helpful?

more options

Trevor,

I guess when Windows updated it reset all my apps back to the defaults, which for email meant using Windows Mail. Unfortunately I've been using Live Mail since forever and have GBs of history that won't move across and, despite Microsoft no longer supporting it, it actually still works on Windows 10. If you're having the same problem, just go to the "Settings" app (type "settings" in the search window on the task bar) and choose "Default apps" from the menu on the left. Email should be the first one that shows up. Good luck!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.