Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has serious problems in Mac OS

  • 4 replies
  • 1 has this problem
  • 23 views
  • Last reply by FredMcD

more options

Version 76 has serious problems in Mac Mojave and Catalina. I'm thinking of moving to another browser if the problems aren't fixed in a few weeks. In Mac Mojave, the UI sometimes blinks and sometimes becomes black. I had to restart the app but it happened quite frequently. After updating to Catalina, all shortcuts are unusable, most right click menus are blank and even the menu bar is blank. When hovering the mouse over the menu bar, nothing displays, just blank menus. Sometimes, the app starts up with default UI although I customised it a bit. In those cases, I had to close the tab or even restart the app.

I'm getting disappointed and perhaps I'll move to another browser soon.

Attached screenshots

Chosen solution

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 👍 1

All Replies (4)

more options

The message from webhelp2 above is NOT Mozilla support.

Helpful?

more options

Chosen Solution

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

Thank you very much. I've updated to version 77. It works fine now.

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.