Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why doesn't the spelling check work?

more options

Hi

I looked at a couple other threads on this problem, which said that you have to install a dictionary and (for example), "You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu". But when I right click in a text area, the context menu has no mention of spelling or languages, and I can't find any place in the Options where one would install a dictionary.

Besides which, why doesn't Firefox tell the poor user that he has to install a dictionary, or put something about it by the check-box in the Options that refers to the spelling checker? And why, in the past, did I never have this problem with Firefox, but only now with a new computer? (Windows 10 as before.)

Chosen solution

Hi, I agree it isn't obvious that you might need one, but depending on your locale, you may need to install a Dictionary to use the Spell checker (not Language Pack - which changes the User Interface) from https://addons.mozilla.org/en-GB/firefox/language-tools/

How do I use the Firefox spell checker?

When installed you will see it in 3-bar menu > Add-ons > Dictionaries. (If no dictionary is installed, 'Dictionaries' will not be listed).

If it doesn't work after installation, restart Firefox.

Don't know why you haven't had to install one before - most of us on here are other users like you, and not Mozilla employees.

If you want to submit feedback to Mozilla you can do it here https://qsurvey.mozilla.com/s3/FirefoxInput/ (This can also be accessed from 3-bar menu > Help > Submit Feedback).

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Hi, I agree it isn't obvious that you might need one, but depending on your locale, you may need to install a Dictionary to use the Spell checker (not Language Pack - which changes the User Interface) from https://addons.mozilla.org/en-GB/firefox/language-tools/

How do I use the Firefox spell checker?

When installed you will see it in 3-bar menu > Add-ons > Dictionaries. (If no dictionary is installed, 'Dictionaries' will not be listed).

If it doesn't work after installation, restart Firefox.

Don't know why you haven't had to install one before - most of us on here are other users like you, and not Mozilla employees.

If you want to submit feedback to Mozilla you can do it here https://qsurvey.mozilla.com/s3/FirefoxInput/ (This can also be accessed from 3-bar menu > Help > Submit Feedback).

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

Thanks. First I clicked on https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker from your reply. It said that to add a dictionary I should right-click in a text area of more than one line, and I would see an item "Languages", and then an item "Add dictionaries...". But it wasn't true. (Maybe because I didn't have any dictionary at all...)

Then I clicked on https://addons.mozilla.org/en-GB/firefox/language-tools/ from your reply. It said at the top, "Available for your locale" and then two dictionaries for British spelling. Then there was a long list of other "locales" (which were not locales at all, but languages or language varieties). I found a "locale" called "English (US)", so I clicked on the "English United States Dictionary" to the right, and it worked! Even though that was not listed as "available for my locale".

So it's' quite confusing, but now it works. I think I will submit feedback to Mozilla!

Helpful?

more options

Hi!

The spellchecker works well here in this box ('Support moz://a), but as you can see on the attached file it has a strange behaviour on 'Gmail'.

Could you please tell me how can I solve this problem?

Thanks, cs

Helpful?

more options

cs,

I use the basic HTML @ Gmail. Check your Google preferences for Gmail. It looks like you are getting two separate spell checks that are "fighting each other".

I had similar happen with a different Web Mail portal; I disabled one, then the other, and then used the one that worked best for me which happened be the one in Firefox.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.