Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Vimeo - Player error The player is having trouble.

  • 10 replies
  • 1 has this problem
  • 356 views
  • Last reply by McCoy

more options

[Ubuntu 20.04 - Firefox 76] When I try to see any Vimeo video I get the error you see in the image

Player error The player is having trouble. We’ll have it back up and running as soon as possible.

In Windows10 everything is ok

Attached screenshots

Chosen solution

Hello   rob,palloni,

Would you please make sure you that you have FFmpeg installed :

https://linuxize.com/post/how-to-install-ffmpeg-on-ubuntu-18-04/

'Hope this helps .....

Read this answer in context 👍 1

All Replies (10)

more options

Chosen Solution

Hello   rob,palloni,

Would you please make sure you that you have FFmpeg installed :

https://linuxize.com/post/how-to-install-ffmpeg-on-ubuntu-18-04/

'Hope this helps .....

Helpful?

more options

Hello, I installed ffmpeg but if I try to reload the video I get the same error. Thanks anyway

Helpful?

more options

rob.palloni said

Hello, I installed ffmpeg but if I try to reload the video I get the same error. Thanks anyway

I've been searching for another possible solution, to no avail.

This "troubleshoot" page doesn't mention that particular message   -   maybe you could contact them (you'll have to scroll all the way down) :

https://vimeo.zendesk.com/hc/en-us/articles/115015677227-Troubleshoot-player-error-messages

But maybe wait a while and see if someone else here (who's familiar with Linux ) will come to your rescue .....

Helpful?

more options

The message is in the page you mentioned and I've already sent a message before landing here in the mozilla support. No answer yet anyway.

Helpful?

more options

rp said

The message is in the page you mentioned and I've already sent a message before landing here in the mozilla support. No answer yet anyway.

Oops ...... I see it now;   it doesn't mention the part :   "We’ll have it back up and running as soon as possible" as shown in your original post.

They say to contact them ASAP,  which you did.

I of course don't know how long you've been waiting to get a response (?)

Well,   let's hope that someone here will come up with a solution, other than installing FFmpeg, which didn't work.

Helpful?

more options

rp said

In Windows10 everything is ok

Using Firefox or another browser ?

Helpful?

more options

Anything related to this issue in the Web Console ?

Works for me on Linux. I see the highlighted TP shield, but nothing important seems to be blocked It is a MP4 (video/mp4 file from skyfire.vimeocdn.com


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

Thanks cor-el. I've already tried many of the things you mentioned with the exception of the Web Console. Below you find the error I get. [I have DRM content checked]

The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4, video/mp4;....

Helpful?

more options

Ok guys! Solved! McCoy suggestion to install ffmpeg was correct. But instead of installing it with snap you should use apt-get

DO NOT USE: sudo snap install ffmpeg

USE: sudo apt-get install ffmpeg

Thanks guys, you are awesome [@McCoy, It might be of help to add the command to use in the top answer]

Modified by rp

Helpful?

more options

rp said

Ok guys! Solved! McCoy suggestion to install ffmpeg was correct.
But instead of installing it with snap you should use apt-get

DO NOT USE: sudo snap install ffmpeg
USE: sudo snap install ffmpeg

Thank you for letting us know   -   greatly appreciated !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.