Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Twitter not loading - cookie issue?

  • 7 replies
  • 1 has this problem
  • 12 views
  • Last reply by cor-el

more options

I'm using a completely clean (reinstalled) version of firefox. I'm not logged into a profile. I'm still having the same problem.

If I go onto twitter for the first time, it loads fine and I can move around pages.

As soon as I leave the site, then return, none of the internal twitter timelines load - I get the twitter message 'something has gone wrong'.

If I delete all my cookies and revisit twitter, it works. But again, if I leave the site and come back immediately, the problem comes back and nothing loads.

Anyone experienced this/know what I can do?

Thanks

All Replies (7)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}
+++++++++++++++++++++++++++++++++++++++++
https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

Helpful?

more options

Hi

Thanks for your reply.

Safe mode didn't work, and disabling hardware acceleration didn't work either.

I can get into twitter via private browsing, but it's not ideal.

Deleting history works temporarily. However as soon as I've visited twitter even once, it stops working again until I've cleared the cookies again.

It seems like every time I visit it it's putting on a corrupted cookie that prevents it working, but I've no ideal how to avoid this.

Helpful?

more options

Try disabling Tracking Protection {web link}

Helpful?

more options

Unfortunately that didn't work either...

Helpful?

more options

Does this work properly in Private Browsing mode (PB mode doesn't use regular cookies and the disk cache) ?

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Hi

Thanks for your reply. Unfortunately I didn't have any luck with that. I found cookies.sqlite and cookies.sqlite -wal and deleted them, but the problem remained.

Yes in private browsing mode it loads absolutely fine.

Tom

Helpful?

more options

You did remove cookies.sqlite when Firefox was closed because the cookies.sqlite-wal temp file would only be present when Firefox is running.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.