Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox updated overnight. this morning it will not open my hotmail/outlook.com email. No error messages, just a refusal to go to any of the pages. help!

  • 1 reply
  • 2 have this problem
  • 70 views
  • Last reply by Scribe

more options

since the update last night, Firefox will not open any outlook.com or hotmail.com page. It doesn't give an error message it simply won't go to the pages, sits and does nothing. It is accessing other pages fine. I need my email! Does anyone know how to fix this? Even if I search "outlook.com" on google, and then click one of the resulting links....nothing.

Chosen solution

Hi, try deleting ALL references to Outlook. To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for Outlook by typing it into the Search History field in the top-right corner. Now in the search results, right-click on Outlook and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a minute or two to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox


If the above doesn't help, hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Read this answer in context 👍 2

All Replies (1)

more options

Chosen Solution

Hi, try deleting ALL references to Outlook. To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for Outlook by typing it into the Search History field in the top-right corner. Now in the search results, right-click on Outlook and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a minute or two to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox


If the above doesn't help, hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.