Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox automatically opens in fullscreen mode. How do I stop this?

  • 2 replies
  • 1 has this problem
  • 115 views
  • Last reply by cor-el

more options

Whenever I open fire fox it automatically opens in fullscreen. Hitting F11 does nothing. I open it in safe mode and I see the address and search bar and everything but I am unable to click on them and honestly it doesn't even look right when I open it up in safe. I provided pictures. I have been all over the settings and looked into multiple forums that all say the same things and tells you how to get out of fullscreen mode but not anything on how to stop it from happening automatically on open. I have uninstalled and re-installed as well.

Anyone have any insight?

Attached screenshots

Chosen solution

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

Helpful?

more options

Make sure you run Firefox in desktop mode and not in tablet mode.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.