Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do I get the old adress search bar back? The new one really annoys me

  • 13 replies
  • 5 have this problem
  • 283 views
  • Last reply by jscher2000

more options

How do I get the old adress search bar back? The new one really annoys me. Please help

Chosen solution

Rexxo said

How do I get the old adress search bar back? The new one really annoys me. Please help

Hello Rexxo,

This is a temporary fix (so I'm told), but I am optimistically hoping that they will give us the opportunity to permanently disable this new feature.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of : setting the value of first preference to "false" will do that)

Read this answer in context 👍 8

All Replies (13)

more options

Chosen Solution

Rexxo said

How do I get the old adress search bar back? The new one really annoys me. Please help

Hello Rexxo,

This is a temporary fix (so I'm told), but I am optimistically hoping that they will give us the opportunity to permanently disable this new feature.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of : setting the value of first preference to "false" will do that)

Modified by McCoy

Helpful?

more options

I can´t thank you enough! It worked perfectly =) I was a bit afraid that I had to use Opera since I don´t use Chrome at all. So again, MASSIVE thank you!

Helpful?

more options

Rexxo said

I can´t thank you enough! It worked perfectly =) I was a bit afraid that I had to use Opera since I don´t use Chrome at all. So again, MASSIVE thank you!

My pleasure  ! (no Opera, there's way more music in Firefox ....)

Would you be so kind as to mark my post as Chosen Solution ?

It's the "Solved the problem" button to the right of my first post.

Thank you in advance !

Helpful?

more options

Yes I really like Firefox, so thanks to you I will stick to it :) Yes of course I will, no problemo!

Helpful?

more options

I have the same issue. Why change something that is not broken.

Helpful?

more options

hofee said

Why change something that is not broken.

'Couldn't agree more ....

@ Rexxo and @ hofee :

Would you consider submitting feedback, using this link :

https://qsurvey.mozilla.com/s3/FirefoxInput/

Let them know how you feel about this 'new feature' (might help).

Helpful?

more options

Thank you! I can't stand this new search bar features. So glad to have found this fix! <3 And yes, I left feedback on this stinker new feature!

Helpful?

more options

I agree 100%, it's really annoying and distracting. And there is no point to it. Like a lot of changes Google does, they just change things for the sake of changing. I will try the above fix, hope I can do it... Just did it. THANK YOU!~

Modified by crankylandlord

Helpful?

more options

This does not work any more with the 77.0 update.

Helpful?

more options

Yetzt- thanks for the heads up. I hate the big search bar so much that I had set my settings not to update because I don't want to be stuck with. Luckily 77.0 did not download and install yet..

Helpful?

more options

The old address bar functionality has been removed as of Firefox 78. Don't update past version 77 if you want your address bar to work properly.

Helpful?

more options

CountFrackula said

The old address bar functionality has been removed as of Firefox 78. Don't update past version 77 if you want your address bar to work properly.

Yes its really annoying. To fix now you have to add userChrome.css code.

Many steps, it took a long time for me to do it. Here is the thread with the info: https://support.mozilla.org/en-US/questions/1283911?page=1

Helpful?

more options

crankylandlord said

I hate the big search bar so much that I had set my settings not to update because I don't want to be stuck with. Luckily 77.0 did not download and install yet..

Firefox 78 has some changes:

I. How to Prevent a List Dropping Automatically

The name of the browser.urlbar.openViewOnFocus preference changed in Firefox 78 to browser.urlbar.suggest.topsites, and you now can toggle that off using a checkbox on the Options/Preferences page:

II. Automatic Enlargement of the Address Bar on Focus

Firefox 78 will not initially animate/enlarge when the cursor enters the box *if* you have a system-level preference for reduced animations. You also can create a new preference in about:config if you do not have the option to set it at the system level. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 0, skip to step (4).

(3) On the bar with the preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 1 (double-click to edit if necessary) and click the blue checkmark button or press Enter to save the change.

Screenshot sequence attached for reference.

III. Changing the Automatic List from New Tab Page Top Sites to the Old List

Unfortunately, turning off the Top Sites section of the Firefox Home / new tab page no longer does this. To summon the old list, you can type a space in the address bar instead.

You also can make the Top Sites list more useful to you by taking control of its contents. Either:

(A) Remove the pre-pinned and default items so Firefox fills it from your own history

(B) Replace the pre-pinned and default items with your own selection of items (this may be easier after Firefox has filled in sites from history than adding them all from scratch)

More info in this article: Customize the New Tab page

If you previously turned off the Top Sites section, you'll need to turn that back on: Hide or display content in New Tab

You may want to add at least one more row of Top Sites to the page in preparation for a change in Firefox 79 that will expand the list beyond 8.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.