Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to get rid of scrolldown bar in search bar?

  • 8 replies
  • 1 has this problem
  • 24 views
  • Last reply by konahrik20

more options

I think this is a new thing but there's now a scrolldown bar when using the search bar and it's really annoying. It used to give me all the suggestions without the scrolldown bar and it's an extra thing that's unnecessary. Does anyone know how to revert back to not having it and getting everything suggested?

Attached screenshots

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 1

All Replies (8)

more options

Hit the Change Search Settings at the bottom of that Menu and de-select Provide search suggestions in about:preferences#search .

The other 2 items for the Default Search Engine pertain to doing searches from the Address Bar, not the Search Bar; but when the mail item is un-ticked they will be diabled, too..

more options

Hmm, I don't normally show search engine suggestions, but when I do, I don't get a scroll bar.

Do you have a multi-monitor setup where you see this problem on the lower resolution monitor but not the higher resolution monitor?

Have you applied any user interface modifications using an optional userChrome.css file?

more options

jscher2000 said

Hmm, I don't normally show search engine suggestions, but when I do, I don't get a scroll bar. Do you have a multi-monitor setup where you see this problem on the lower resolution monitor but not the higher resolution monitor? Have you applied any user interface modifications using an optional userChrome.css file?

Nope, just one monitor. And to the best of my knowledge I haven't done anything with the userChrome.css file.

more options

the-edmeister said

Hit the Change Search Settings at the bottom of that Menu and de-select Provide search suggestions in about:preferences#search . The other 2 items for the Default Search Engine pertain to doing searches from the Address Bar, not the Search Bar; but when the mail item is un-ticked they will be diabled, too..

The problem is that I want the search suggestions but not the scrolldown bar that's shown up.

more options

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

That does seem to stop it from coming back, but I'm not sure if it's an extension or hardware acceleration that's doing it.

more options

Did you verify that you do not have a userChrome.css file in the chrome folder because Safe Mode disables this file as well?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
more options

Nope, no userChrome.css file but after trying it in Safe Mode and restarting it seems to have went away.