Search Support

Spell check not working

  • 6 replies
  • 1 has this problem
  • 11 views
  • Last reply by FredMcD

more options

Spell checking doesn't seem to be working in form text inputs, both single and multi-line. I have my language set to English (United Kingdom) and I've also tried setting layout.spellcheckDefault to 2.

When I right click over such a form text input, the context menu has no mention of spelling or languages. I'm in a corporate environment so it's possible they're doing something with the config?

Chosen solution

The en-GB Firefox version doesn't come with a builtin dictionary unlike the en-US Firefox version due to licensing issues, so you need to install this dictionary yourself.

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

Read this answer in context 👍 0

All Replies (6)

more options

BTW, I have "Check your spelling as you type" ticked and the same fields on the same page on my personal machine show the expected spelling context menu items.

Helpful?

more options

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker


Grammarly for Firefox by Grammarly https://addons.mozilla.org/en-US/firefox/addon/grammarly-1/

Grammarly will help you communicate more effectively. As you type, Grammarly flags mistakes and helps you make sure your messages, documents, and social media posts are clear, mistake-free, and impactful.

Helpful?

more options

Chosen Solution

The en-GB Firefox version doesn't come with a builtin dictionary unlike the en-US Firefox version due to licensing issues, so you need to install this dictionary yourself.

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

Helpful?

more options

cor-el said

Note that for spell check you need a dictionary.

Well, that's embarrassing...

Many thanks for pointing out my obvious mistake!

Helpful?

more options

Hi

The "Chosen Solution" says, "You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu". But the original poster said, "When I right click over such a form text input, the context menu has no mention of spelling or languages".

So how did he solve the problem?

I have the same problem. When I right-click in a text area, there's no mention of spelling or languages, and I can't find any place in the Options where one would install a dictionary.

Besides which, why doesn't Firefox tell the poor user that he has to install a dictionary, or put something about it by the check-box in the Options that refers to the spelling checker? And why, in the past, did I never have this problem with Firefox, but only now with a new computer? (Windows 10 as before.)

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.