Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Wrong Right-click menu displayed on some web sites

more options

On several web sites (such as Google - but also on Mozilla Release Notes) right-clicking on a URL link displays an incorrect drop-down menu. See attached screenshot with Mozilla URL visible. This issue makes it impossible to e.g. open a link in a new Tab.

Same issue seen on Mac and Windows 10 platforms (Firefox 73.0.1)

Attached screenshots

All Replies (5)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

I will try this when I encounter this issue the next time.

What makes testing this tricky is, that the issue may go away if I restart Firefox. Please note this is not consistent on any web site. I often see it on Google search results. After restart, Google is ok again.

Helpful?

more options

The menu shows the fly-out for opening a link in a container as shown in the help article, but obviously the menu is broken.

Ref. Multi-Account Containers

I wonder if it could be related to the Facebook Container extension. Could you try disabling that extension for half a day and see whether it makes any difference? You can right-click its "fence" icon, click "Manage extension", then slide the on-off switch to off.

If the problem is caused by that extension, we hopefully can get that feedback to the developers for further testing.

Helpful?

more options

I have disabled the Facebook Container extension for now, and will report back immediately, if I encounter the problem again.

Unfortunately - as there can be no negative proof - I cannot tell for sure, if the problem has gone away. The issue is quite intermittent, and may exhibit itself only once in a blue moon...

I just need to keep the extension OFF and follow this up in a week or two...

Helpful?

more options

During the past two week time period, when I have kept the Facebook Container extension disabled, I have not encountered this issue at all.

It looks very much like it is a intermittent problem with this extension.

I will enable the extension now, and report back if /when the issue re-occurs.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.