Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

FF 74.0: issue with menu keyboard shortcut Alt+D

  • 5 replies
  • 2 have this problem
  • 7 views
  • Last reply by cor-el

more options

With the German language pack "Deutsch (DE)", the keyboard shortcut for the file menu is Alt+D (Datei=File). Since FF 74.0 (64-Bit), it doesn't work anymore. Instead, the shortcut sets the focus to the location bar. Any other keyboard shortcut works.

Is it a bug? Is there a work around?

All Replies (5)

more options

I'm not sure.

Try refreshing FF.

Helpful?

more options

Because of this strange issue, I recently completely reinstalled Xubuntu and Firefox. Sorry, if I had to reinstall/refresh FF all the time, I'd rather stop using my favourite browser.

BTW: It also happens on my Win8.1 PC an FF 74.0.

THIS SHOWS, THAT IT IS A BUG, NOT MY FAILURE OR CONFIG.

Helpful?

more options

This issue has been reported before for the German Firefox version. In the German version Alt+D is reserved for the File menu (Datei) and thus isn't available for focusing the location bar.


  • /questions/1230509 Alt + D showing menu instead of fucusing search bar
  • Bug 1485052 - Alt + D opens the file menu for german users instead of focusing the search bar

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

You can possibly use Firefox in a locale other than DE if you want to use Alt+D for the location bar.

Modified by cor-el

Helpful?

more options

I realize this doesn't change the shortcut back, but does it work to separate those: tap Alt to activate the menu bar, then tap D ?

Helpful?

more options

Sorry I appear to have misread your question.

I installed the DE language pack and can confirm the changed behavior.

It still shows "s" as access key for the urlbar access key in browser.dtd.

Maybe this is related to switching to fluent and some access keys can no longer be overridden by a localization.

To make the Alt key work to show the menu bar, you need to have this pref set to true on the about:config page.

  • ui.key.menuAccessKeyFocuses = true

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.