Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Since FF 69 starting (not loading!) web sites frequently needs more than 10 seconds under Xubuntu

  • 22 Antworten
  • 1 hat dieses Problem
  • 28 Aufrufe
  • Letzte Antwort von ebfried2000

more options

Since FF 69 the starting (not the loading!) of websites frequently lasts more than 10 seconds under Xubuntu. The tab remains empty during this waiting time, while no sign of the loading process can be seen: The tab header shows no title, only the URL. The animated loading icon of the tab header is not shown. The status bar shows no activity. For about 5 to 20 seconds it looks like the tab is frozen. (See hardcopy.) This phenomenon occurs irregularly, but repeatedly, approximately with 10-20 percent of all calls, regardless of the requested URLs. It typically occurs piled within a random period, that lasts between a some seconds and several minutes. It also happens in safe mode, regardless of the used profile (even an unmodified new profile) and both in private an non-private windows. As far as I can judge, the troubleshooting Information shows no abnormalities. There are no issues with the internet connection. I've been using Firefox trouble-free for more than 10 years, but this phenomenon only occurred since Firefox 69.0.

Angefügte Screenshots

Ausgewählte Lösung

I completely re-installed Xubuntu 18.04.3. Now, the problem has finally gone.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (20)

more options

Hello ebfried2000,

This could be caused by uBlock Origin : apart from the fact that you need to update the add-on to the latest version (1.22.2) - please see the 5th review :


To find out if this is indeed the culprit : would you please disable it (for now) and see if that will make a difference ?

more options

Thanks for your answer, McCoy! As I mentioned, this also happens in FF safe mode. Since in safe mode all addons are disabled, no addon can be the cause.

more options

ebfried2000 said

As I mentioned, this also happens in FF safe mode. Since in safe mode all addons are disabled, no addon can be the cause.

Oops - I missed that (sorry .... ).

But you really do need to update uBlock Origin, though - would you please ?

As I was almost certain that this extension would be the culprit, I can't think of any other reason - I'm hoping that someone else does .....

more options

McCoy said

But you really do need to update uBlock Origin, though - would you please ?

Yes, i'll do this, thanks!

more options

It's strange that Firefox seems to be waiting for something: the reload arrow hasn't changed to an X and there is no status message in the lower left corner.

A couple ideas for further investigation:


Open the Network Monitor in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Linux/Windows) Ctrl+Shift+e

When you reload the page, Firefox should start listing all the files it is requesting, along with information about whether the request was successful.


  • Does Firefox immediately list the URL of the page as a request -- even if nothing is happening -- or does it not even list the URL until the long delay is over?
  • The time bars are color coded to provide information about what Firefox was doing all that time. If you click the request, then you can change the panel on the right (usually Headers) to Timings. You may need to use a little triangle at the far end of the bar if Timings is not visible. Do you see a long period of "Blocked"?


The next time you see this starting, could you turn "Work Offline" on and off (I'd count to 10 in between) to see whether that changes anything? It probably will interrupt some background communications such as your email site receiving new messages.

If you want to try it, you can use either:

  • menu button > Web Developer > Work Offline
  • (men bar) File > Work Offline
more options

Thank you for the detailed answer.

The result of this investigation:

(1) When I tried to open the Network Monitor with "Ctrl+Shift+e" during such a freeze, nothing happened. The tool bar in the lower part of the tab didn't open until the end of the delay. Even after the delay, it is not shown until another "Ctrl+Shift+e".

(2) After turning on "Work Offline", immediately an "Offline Mode" error message is shown in the affected tab and remains after turning the switch back on "off".

Geändert am von ebfried2000

more options

After investigation (1), I got the idea that there might be a conflict between the GUI and my video driver. Just for this case I add the device information. (The video driver is up to date.)

$ lspci -nnk | grep -A3 "\[03..\]:" 01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000] [1002:9616] Subsystem: ASUSTeK Computer Inc. RS780L [Radeon 3000] [1043:8388] Kernel driver in use: radeon Kernel modules: radeon

xorg.conf: Section "Device" Identifier "Configured Video Device" Driver "radeon" EndSection

Maybe, a new optimization in FF 69 needs some Option to be specified, such as "NoAccel". "AccelMethod" etc.?

Update: I tried "NoAccel", nothing changed.

Geändert am von ebfried2000

more options

Hello again ebfried2000,

Would you take a look at this article and see if maybe you'll find
some useful tips :


more options

With Firefox 70.0 the problem seems to be gone. I'll observe it for a while and if it's really fixed, I will mark the issue as solved,

more options

Try updating your browser

more options

Bahu said

Try updating your browser

You answers without reading the thread.

more options

Unfortunately, with Firefox 71.0 the problem is back again.

more options

Safe Mode no longer neccesarily means Add Ons are disabled. Check the Add Ons options to make sure it is not enabled while in Safe Mode.

more options

This happens even without any AddOns.

more options

With FF 71.0, the situation became even worse. Some of these "waiting periods" never stop, i.e. FF hangs up.

more options

Nothing changed in FF 72.0.1

more options

I've been using firefox now for more than 15 years now.

After more than four moths with this problem, I was so desperate, that I finally decided to replace my favorite browser with another one. I tried Opera, but was not satisfied with it.

So I made another try: I completely uninstalled and then re-installed firefox.

Again, nothing has changed.

I used an all-new empty profile.

Again, nothing has changed.

Now I have one burning question: When I installed firefox all-new and have used an all-new profile, without any add-ons etc. - and the problem is still there - what the hell can I try more?

Could it be caused by my system (Ubuntu 18.04.3 LTS with xfce desktop)? But why then is firefox the only application with such problems? (BTW, I even tried other desktops, which didn't solve the problem.)

What else could I try to solve the problem?

more options

Maybe take a look at this :


(you will also come across this page, when you read the first link I posted)

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

more options

@cor-el As I mentioned twice, I vainly tried a completely new profile several times.

  1. 1
  2. 2