Search Support

Firefox refuses to allow me to connect to my centurylink.net email page

  • 11 replies
  • 3 have this problem
  • 307 views
  • Last reply by chasdobie

more options

before the most recent update I have no trouble connecting to my centurylink.net email.....and now after the update I get this message:

Secure Connection Failed

An error occurred during a connection to webmail.centurylink.net. PR_CONNECT_RESET_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Nothing I do will allow it to connect. yet it seems to work fine in chrome or internet explorer, just not firefox.

Chosen solution

Hi draculas.tomb, PR_CONNECT_RESET_ERROR indicates that the destination server or a server along the way sent a RST to Firefox to terminate the attempted connection. We sometimes can guess why that happened, but often a lot of guesses are needed.

In addition to the first set of questions:

Do you know whether your Firefox has been updated to use DNS over HTTPS? This feature bypasses your ISP's DNS servers and runs queries from a point on the web (by default, using Cloudflare). There usually would be a little panel dropping from the main bar at some point about that. More info: Firefox DNS-over-HTTPS.

DoH sometimes causes issues with sites that may have different addresses for different networks of users. There's a way to make a site-specific exception, but first, is it even turned on?

You can check whether this is "on" on the Options page, and turn it off as a test if it's turned on now:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type dns and Firefox should filter to the "Network Settings" section. Click the Setting button and scan down or scroll down to the last part to find the relevant checkbox (see attachment):

Read this answer in context 👍 1

All Replies (11)

more options

Helpful?

more options

Chosen Solution

Hi draculas.tomb, PR_CONNECT_RESET_ERROR indicates that the destination server or a server along the way sent a RST to Firefox to terminate the attempted connection. We sometimes can guess why that happened, but often a lot of guesses are needed.

In addition to the first set of questions:

Do you know whether your Firefox has been updated to use DNS over HTTPS? This feature bypasses your ISP's DNS servers and runs queries from a point on the web (by default, using Cloudflare). There usually would be a little panel dropping from the main bar at some point about that. More info: Firefox DNS-over-HTTPS.

DoH sometimes causes issues with sites that may have different addresses for different networks of users. There's a way to make a site-specific exception, but first, is it even turned on?

You can check whether this is "on" on the Options page, and turn it off as a test if it's turned on now:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type dns and Firefox should filter to the "Network Settings" section. Click the Setting button and scan down or scroll down to the last part to find the relevant checkbox (see attachment):

Helpful?

more options

I got it solved. Seems it didnt like the link to my email so what I had to do was go to the century link main page, then go to email, and then to my email account.

Once I did that I was able to get in and I then shut down and restarted my browser and went to home tab (where my email is listed) and it popped right up. Dont know why I got the error because its now doing exactly what I wanted it to do. Just hope the next update does not force me to jump through hoops again

Helpful?

more options

Hi draculas.tomb, it sounds as though my post was not the solution, but navigating in a different way and perhaps updating your bookmark? For the benefit of others who find this thread, I suggest removing "Solution" from my reply and putting it next to yours.

Helpful?

more options

I'm having the same problem (Firefox 74.0, 64-bit, Windows 10 on a desktop). My anti-virus is ESET. I tried dis-enabling SSL/TLS, on ESET, then enabling it again, then re-starting my computer, per the instructions elsewhere in these pages, but my isp's website is no longer accessible.

I somehow doubt that it is the fault of ESET, because the Chrome, Edge, and Brave web browsers access the website from the same computer, with no problems

And "Enable DNS over HTTPS" has always been enabled on Firefox.

For what it's worth, the website I can't access is https://www.superaje.com/

Helpful?

more options

Hi chasdobie, are you getting PR_CONNECT_RESET_ERROR code or are you getting the SSL_ERROR_UNSUPPORTED_VERSION code? I see that second one at the link you provided.

Helpful?

more options

Hi jscher2000 -- I just tried it and got PR_CONNECT_RESET_ERROR

Since I posted my original message I went into Firefox config -- entered "about:config" -- and now I forget what I searched for -- just copied the string from something I saw on one of these pages -- and added superaje.com to the list of domains to not require a secure connection. Didn't make any difference, as it still won't connect.

However, a few minutes ago I got an email from my isp's support, saying this has been a problem for a few of their customers and they know how to fix it. They want me to phone them tomorrow and they'll talk me through it.

This isn't a huge deal yet -- my email isn't affected and the next time I'll want to access their website is this summer when I'll want to use webmail.

Helpful?

more options

My isp's support found the solution to the problem -- specifically getting the PR_CONNECT_RESET_ERROR when connecting to their website.

Like flying an airplane, it's dead simple when you know how to do it :-)

In Firefox's address bar, type "about:config" without the quotes. You'll get a screen warning you it's dangerous to continue -- continue anyway.

You'll get a search field -- enter TLS

You'll get a screen of entries -- scroll down to "security.tls.version.enable-deprecated" which, to the right of it, should be set to "false". Set it to "true" by clicking the icon to the far right of the line.

You should immediately be able to access the website.

Helpful?

more options

Hi chasdobie, hopefully they will eventually update their site protcol security from the 1990's to the 2010's so you don't have to do that!

Helpful?

more options

Note that you shouldn't have to use the about:config page to flip the security.tls.version.enable-deprecated pref. On the error page there is a blue "Enable TLS 1.0 and 1.1" button and clicking this button will set this pref to true.

Modified by cor-el

Helpful?

more options

cor-el: That would have made things much easier, but on my error screen (Windows 10, 64-bit on a desk-top) there was no such button. The only option I had was to "Try Again", which always failed, or to click a link which sent me to a problem FAQ, which eventually led me to this support forum.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.