Search Support

can't add an address to autofill

  • 31 replies
  • 1 has this problem
  • 30 views
  • Last reply by jscher2000

more options

Add button does not respond. Doesn't work in Safe Mode.

Chosen solution

Hi Robert, thank you for that!

RobertHooton said

Click the Add button:

TypeError: mutation.target.closest is not a function l10n.js:44:58

TypeError: contentPane is null subdialogs.js:434:7

I get that first one, too. Must not be fatal.

The second one is part of the code path for the dialog being too tall and needing a scroll bar. (Line 434) I think we found the problem.

As a test, I shrank the vertical area of the page by opening the developer tools panel (Ctrl+Shift+i). Depending on the height left for the page, the Add New Address would fail to show and I would get that error in the Browser Console.

Could you temporarily reduce the zoom level on the Options page (hold down Ctrl and tap the - key a couple times) and see whether that lets you add the address?

Read this answer in context 👍 0

All Replies (20)

more options

RobertHooton said

Add button does not respond. Doesn't work in Safe Mode.

Hello Robert,

Are you located in either the US, Canada or Germany ? If not, that might explain why the button doesn't respond.

See : https://wiki.mozilla.org/Firefox/Features/Form_Autofill#Child_Pages

Helpful?

more options

I am in the US.

Helpful?

more options

I am going to try uninstalling and reinstalling Firefox.

Helpful?

more options

Reinstalled Firefox and now Autofill has disappeared from the Privacy and Security options.  ????

Helpful?

more options

RobertHooton said

Reinstalled Firefox and now Autofill has disappeared from the Privacy and Security options.  ????

Oh boy ....

Probably a rhetorical question, but did you make sure you installed the en_US Firefox version ?

Helpful?

more options

Installed Firefox Installer.exe from the Mozilla website. See attachment for Property details.

Helpful?

more options

Would you check this please :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

extensions.formautofill.available and make sure its value is set to on.

if you had to change the value; then close and restart Firefox.

Is "Forms and Autofill" back ?

Modified by McCoy

Helpful?

more options

It was set to detect, changed to true. Closed and restarted Firefox. "Forms and Autofill" is still absent.

Helpful?

more options

RobertHooton said

It was set to detect, changed to true. Closed and restarted Firefox. "Forms and Autofill" is still absent.

    You should set the value to on .....

    Would you give that a try ?

Helpful?

more options

Set extensions.formautofill.available to "on". Restarted Firefox and Forms and Autofill are back. Thanks for that.

However, when I choose Saved Addresses, Add, the Add button does not do anything. I can't add an address. This was the original problem.

Helpful?

more options

Would you check this on the "about:config" page :

extensions.formautofill.addresses.enabled

Its value should be set to true

Helpful?

more options

If everything else fails, then let's try Firefox in Safe Mode :

In your original piot you say "Doesn't work in Safe Mode" - I don't know if that means that the button doesn't work in Safe Mode, or the problem doesn't excist in Safe Mode (?)

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Modified by McCoy

Helpful?

more options

I tried this originally. It still doesn't activate the "Add" button.

Helpful?

more options

McCoy said

Would you check this on the "about:config" page :
extensions.formautofill.addresses.enabled
Its value should be set to true

    Have you checked this ?

Helpful?

more options

extensions.formautofill.addresses.enabled was set to 'true'.

Helpful?

more options

I'm all out of ideas (so sorry .... )

I hope that someone else will come to your rescue !

Helpful?

more options

I've sent a private message to a fellow contributor and asked
him to come to your rescue.

Helpful?

more options

Thanks for your help. I appreciate it.

Helpful?

more options

It's 00.31AM over here, but before I'm off to bed I want to ask you to
check this preference on the "about:config" page (just to make sure).

extensions.formautofill.supportedCountries

Helpful?

more options

US, already looked at that. Where are you? I'm in Texas.

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.