X
Tap here to go to the mobile version of the site.

Support Forum

Cannot change text colour in 68.4.1

Posted

The normal route of clicking on write email >format>text colour used to go to a drop down menu where you simply clicked on the colour on a large ball. Now it has a silly drop down which stays on black whatever you do. Why do developers mess up things that have functioned the same way for years successfully?

The normal route of clicking on write email >format>text colour used to go to a drop down menu where you simply clicked on the colour on a large ball. Now it has a silly drop down which stays on black whatever you do. Why do developers mess up things that have functioned the same way for years successfully?

Chosen solution

Set your Colors preferences ... under the "Colors" Button ... like this:

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_2) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.4 Safari/605.1.15

More Information

sfhowes
  • Top 10 Contributor
1924 solutions 9630 answers

The text color on Mac is explained here, followed by a video:

https://support.mozilla.org/en-US/questions/1276138#answer-1278599

The text color on Mac is explained here, followed by a video: https://support.mozilla.org/en-US/questions/1276138#answer-1278599
Was this helpful to you? 0
Quote

Question owner

Unfortunately, none of this works. It's just a normal Mozilla thing to mess up a simple system that worked and change to something that does not work.

Unfortunately, none of this works. It's just a normal Mozilla thing to mess up a simple system that worked and change to something that does not work.

Modified by hughmoz

Was this helpful to you?
Quote

Question owner

Unfortunately, none of this works.

I cannot see a bug report thing in the stream that you supplied.

I upgraded from an old Thunderbird that was very easy to use and had proper colour icons on the toolbar so that you can see them instead of all of them in black. 13.0.1 or 13.1.0 I think it was, however in Catalina I had to have the latest version of Thunderbird and it is awful. It's just very poor design strategy to have mono colours on toolbatr and a colour choice that does not function.

The colour does not change regardless of changing it and clicking OK, and colour stays black whatever you do. Mozilla are simply not sorting this out. The old system was easy to use and perfect so, why have they messed it up?

Unfortunately, none of this works. I cannot see a bug report thing in the stream that you supplied. I upgraded from an old Thunderbird that was very easy to use and had proper colour icons on the toolbar so that you can see them instead of all of them in black. 13.0.1 or 13.1.0 I think it was, however in Catalina I had to have the latest version of Thunderbird and it is awful. It's just very poor design strategy to have mono colours on toolbatr and a colour choice that does not function. The colour does not change regardless of changing it and clicking OK, and colour stays black whatever you do. Mozilla are simply not sorting this out. The old system was easy to use and perfect so, why have they messed it up?

Modified by hughmoz

Was this helpful to you?
Quote
Sea Mac
  • Top 25 Contributor
19 solutions 137 answers

Easily Solved!!! (it IS a system setting ... you just need to know where to LOOK for it.)

Look carefully at the Color Chooser panel in the First Screenshot. Click on the little color blob at the top (just under the Close Button) to switch to the "Good" color pallet - this shows the Crayons Color selector chosen.

Try clicking on the different icons at the top of the Color Chooser until you find a pallet you like better than your current default.

When you get THIS Color Chooser: slide the slider under the solid black circle all the way to the left. Now you can choose "ANY Color you Like".

At the bottom is a row of "Empty" color chips ... when you get a "Custom" color you want to "Persist" you drag it into one of those empty squares - and it will be right there in the color chooser after a restart. You can save a couple dozen of your custom colors here. There is also an eyedropper tool to pick any screen color precisely. https://support.mozilla.org/en-US/questions/1274419#answer-1281433 https://bugzilla.mozilla.org/show_bug.cgi?id=1584772#c8 I keep answering this one over and over again.

Easily Solved!!! (it IS a system setting ... you just need to know where to LOOK for it.) Look carefully at the Color Chooser panel in the First Screenshot. Click on the little color blob at the top (just under the Close Button) to switch to the "Good" color pallet - this shows the Crayons Color selector chosen. Try clicking on the different icons at the top of the Color Chooser until you find a pallet you like better than your current default. When you get THIS Color Chooser: slide the slider under the solid black circle all the way to the left. Now you can choose "ANY Color you Like". At the bottom is a row of "Empty" color chips ... when you get a "Custom" color you want to "Persist" you drag it into one of those empty squares - and it will be right there in the color chooser after a restart. You can save a couple dozen of your custom colors here. There is also an eyedropper tool to pick any screen color precisely. https://support.mozilla.org/en-US/questions/1274419#answer-1281433 https://bugzilla.mozilla.org/show_bug.cgi?id=1584772#c8 I keep answering this one over and over again.

Modified by Sea Mac

Was this helpful to you? 0
Quote

Helpful Reply

It makes no difference as, I have already done that a lot of times already. It's simply Mozilla that have mucked up a previously simple colour choice.

One cannot expect people to keep messing about with settings when on any computer whether PC or Mac one should just be able to alter the colour without spending years trying to do it.

I have used Thunderbird for something like 15 years without ever having a problem changing the text colour and this is just plainly stupid.

Mozilla need to fix it.

It makes no difference as, I have already done that a lot of times already. It's simply Mozilla that have mucked up a previously simple colour choice. One cannot expect people to keep messing about with settings when on any computer whether PC or Mac one should just be able to alter the colour without spending years trying to do it. I have used Thunderbird for something like 15 years without ever having a problem changing the text colour and this is just plainly stupid. Mozilla need to fix it.
Was this helpful to you? 1
Quote
Sea Mac
  • Top 25 Contributor
19 solutions 137 answers

Well, I do not have Mac OS X 10.15.2 Catalina so I cannot duplicate this issue.

Would you post a screenshot of the "Catalina" Color Picker? https://support.apple.com/kb/HT201361

I'm pretty sure this issue only exists on Apple's "Latest Greatest" OS - Which my older Mac Computer is NOT Capable of upgrading to - as other Catalina Users are complaining also. TB Developers may need to Patch it for 10.15's new Color Interface ... as Apple has depreciated a LOT of previously needed things in Catalina.

Well, I do not have Mac OS X 10.15.2 Catalina so I cannot duplicate this issue. Would you post a screenshot of the "Catalina" Color Picker? https://support.apple.com/kb/HT201361 I'm pretty sure this issue only exists on Apple's "Latest Greatest" OS - Which my older Mac Computer is NOT Capable of upgrading to - as other Catalina Users are complaining also. TB Developers may need to Patch it for 10.15's new Color Interface ... as Apple has depreciated a LOT of previously needed things in Catalina.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1924 solutions 9630 answers

hughmoz said

It makes no difference as, I have already done that a lot of times already. It's simply Mozilla that have mucked up a previously simple colour choice. One cannot expect people to keep messing about with settings when on any computer whether PC or Mac one should just be able to alter the colour without spending years trying to do it. I have used Thunderbird for something like 15 years without ever having a problem changing the text colour and this is just plainly stupid. Mozilla need to fix it.

Do you have Catalina 10.15.1 or higher? TB uses the system color picker in v. 68.

''hughmoz [[#answer-1283169|said]]'' <blockquote> It makes no difference as, I have already done that a lot of times already. It's simply Mozilla that have mucked up a previously simple colour choice. One cannot expect people to keep messing about with settings when on any computer whether PC or Mac one should just be able to alter the colour without spending years trying to do it. I have used Thunderbird for something like 15 years without ever having a problem changing the text colour and this is just plainly stupid. Mozilla need to fix it. </blockquote> Do you have Catalina [https://answers.microsoft.com/en-us/msoffice/forum/all/eyedropper-in-powerpoint-is-not-working-with-macos/18aa521e-abe7-4d9f-9177-fcb5c4fd224c 10.15.1 or higher]? TB uses the system color picker in v. 68.
Was this helpful to you?
Quote

Question owner

I have Catalina 10.15.2

I have Catalina 10.15.2
Was this helpful to you?
Quote

Helpful Reply

Whatever you choose with the colour picker it reverts to black. You can alter everything in Preferences etc., as in all the links/picture provided and it still stays black. It is a Mozilla problem created by Mozilla.

In Apple mail the Colour picker goes to the colour that you choose. In Thunderbird it only has black that works.

Whatever you choose with the colour picker it reverts to black. You can alter everything in Preferences etc., as in all the links/picture provided and it still stays black. It is a Mozilla problem created by Mozilla. In Apple mail the Colour picker goes to the colour that you choose. In Thunderbird it only has black that works.
Was this helpful to you? 1
Quote
Toad-Hall
  • Top 10 Contributor
1867 solutions 12650 answers

Test for info...Can you confirm: When you try to use 'Color Picker' in Thunderbird, is 'Color picker' otherwise not running for any other program etc. Color Picker is closed?

Test for info...Can you confirm: When you try to use 'Color Picker' in Thunderbird, is 'Color picker' otherwise not running for any other program etc. Color Picker is closed?
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1867 solutions 12650 answers

Test: If you type in a hex colour eg: #37b2c6 and click on 'default' does it change ?

Test: If you type in a hex colour eg: '''#37b2c6''' and click on 'default' does it change ?
Was this helpful to you?
Quote

Question owner

The same colour picker comes up in Apple Mail straight away (as the colour ball) without all the messing about in Thunderbird, and works straightforwardly.

The same colour picker comes up in Apple Mail straight away (as the colour ball) without all the messing about in Thunderbird, and works straightforwardly.

Modified by hughmoz

Was this helpful to you?
Quote

Question owner

If I put n any colour like E.g. blue or #0000ff it changes the colour, but as soon as you start typing the email it reverts to black so, colour choice never functions. The exact same colour picker exists in a Mac for Apple Mail, but it works as Thunderbird used to.

If I put n any colour like E.g. blue or #0000ff it changes the colour, but as soon as you start typing the email it reverts to black so, colour choice never functions. The exact same colour picker exists in a Mac for Apple Mail, but it works as Thunderbird used to.
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1867 solutions 12650 answers

So, you can use the colour picker and in that respect there is nothing wrong, but in thunderbird the small colour text icon remains black and so does actual text. Do a test where you close the color picker BEFORE you click on the OK.

Can you test this in this order:

  1. in Formatting bar, click on the text colour square icon
  2. click on 'Choose colour' to open the MAC color picker'
  3. Select the color with the Mac color picker.
  4. Then close the Mac color picker - this is important.
  5. Finally select OK in the TB color picker.

Does this change the colour of the text icon in Formatting Bar ?

So, you can use the colour picker and in that respect there is nothing wrong, but in thunderbird the small colour text icon remains black and so does actual text. Do a test where you close the color picker BEFORE you click on the OK. Can you test this in this order: # in Formatting bar, click on the text colour square icon # click on 'Choose colour' to open the MAC color picker' # Select the color with the Mac color picker. # Then close the Mac color picker - this is important. # Finally select OK in the TB color picker. Does this change the colour of the text icon in Formatting Bar ?
Was this helpful to you?
Quote

Question owner

Yes, as I have alluded to already in my replies, but as soon as you try and type the box goes black. In the formatting bar it shoes text colour uop and slightly to the left of the background colour. So, you can have both of those correct and yet as soon as you type the text colour square goes black.

Yes, as I have alluded to already in my replies, but as soon as you try and type the box goes black. In the formatting bar it shoes text colour uop and slightly to the left of the background colour. So, you can have both of those correct and yet as soon as you type the text colour square goes black.

Modified by hughmoz

Was this helpful to you?
Quote
Sea Mac
  • Top 25 Contributor
19 solutions 137 answers

I had the EXACT Same Problem last year - I filed a Bug for it: https://bugzilla.mozilla.org/show_bug.cgi?id=1574363

So, let us see if the solution is the same. Look at this setting ... can you check in preferences: Display, Formatting, Under Fonts and Colors click the Colors (button): How is the Drop Down Selector "Override the colors" ... - How is that set?

(Mine accidentally somehow got set to "Always" and that's how I had this problem ... )

I had the EXACT Same Problem last year - I filed a Bug for it: https://bugzilla.mozilla.org/show_bug.cgi?id=1574363 So, let us see if the solution is the same. Look at this setting ... can you check in preferences: Display, Formatting, Under Fonts and Colors click the Colors (button): How is the Drop Down Selector "Override the colors" ... - How is that set? (Mine accidentally somehow got set to "Always" and that's how I had this problem ... )

Modified by Sea Mac

Was this helpful to you? 1
Quote
Sea Mac
  • Top 25 Contributor
19 solutions 137 answers

Chosen Solution

Set your Colors preferences ... under the "Colors" Button ... like this:

Set your Colors preferences ... under the "Colors" Button ... like this:
Was this helpful to you?
Quote

Question owner

Ok now we are getting somewhere. I have got the type the right colour and then found out I had a baby blue background and found eventually that I could alter that in Composition in preferences so, I'm good to go.

Thanks for your perseverance and help.

it is so utterly annoying to spend days on finding out how to do something that was never an issue before and everything was chosen from the text and colour choices on the Thunderbird toolbar.

So, is this caused by Catalina or Mozilla because, It has been a doddle to use Thunderbird for 15 years and now it is unnecessarily complicated?

Thanks for everyones contributions and Sea Mac for nailing it! :)

Ok now we are getting somewhere. I have got the type the right colour and then found out I had a baby blue background and found eventually that I could alter that in Composition in preferences so, I'm good to go. Thanks for your perseverance and help. it is so utterly annoying to spend days on finding out how to do something that was never an issue before and everything was chosen from the text and colour choices on the Thunderbird toolbar. So, is this caused by Catalina or Mozilla because, It has been a doddle to use Thunderbird for 15 years and now it is unnecessarily complicated? Thanks for everyones contributions and Sea Mac for nailing it! :)

Modified by hughmoz

Was this helpful to you?
Quote
Sea Mac
  • Top 25 Contributor
19 solutions 137 answers

No, no: I had the EXACT Same problem and I know your level of frustration. Makes you want to chuck your beloved friend, and all of its data, into a running wood chipper ....

Once you set that darned drop-down selector from "Always" to "Never" the color choices you get out of that lovely color wheel color chooser actually "Stick" and your life goes back to normal.

To any other support volunteers who might be paying attention: THIS is a tricky one!! It seems we only check the colors over ride setting as a last resort and ... whenever colors 'refuse to stick' when selected ... this should be the first setting we check!!!

I had this issue. This little setting SNAFU brought me here: and I even filed a bug about it at Bugzilla (and now I'm an intermittent support volunteer ... because of this). He had this issue. I predict that this issue will be BACK again in a few more months. I even proposed a KB article on "Color Choosing in TB" - and volunteered the "Mac OS" versions custom screenshots for it. https://support.mozilla.org/en-US/forums/knowledge-base-articles/710936?last=77474&page=3 I see I'm going to have to go push that Agenda a bit ... any Windows 10 Support Maven wanna help me with this?

No, no: I had the EXACT Same problem and I know your level of frustration. Makes you want to chuck your beloved friend, and all of its data, into a running wood chipper .... Once you set that darned drop-down selector from "Always" to "Never" the color choices you get out of that lovely color wheel color chooser actually "Stick" and your life goes back to normal. To any other support volunteers who might be paying attention: THIS is a tricky one!! It seems we only check the colors over ride setting as a last resort and ... '''whenever colors 'refuse to stick' when selected''' ... this should be the first setting we check!!! I had this issue. This little setting SNAFU brought me here: and I even filed a bug about it at Bugzilla (and now I'm an intermittent support volunteer ... because of this). He had this issue. I predict that this issue will be BACK again in a few more months. I even proposed a KB article on "Color Choosing in TB" - and volunteered the "Mac OS" versions custom screenshots for it. https://support.mozilla.org/en-US/forums/knowledge-base-articles/710936?last=77474&page=3 I see I'm going to have to go push that Agenda a bit ... any Windows 10 Support Maven wanna help me with this?

Modified by Sea Mac

Was this helpful to you?
Quote

Question owner

But, you have not answers my question about whether this is caused by the Mac OSX or by Mozilla? As I have already said, I have used Thunderbird on PC's from 20 years ago and Mac's for the last 15 years and never had this issue before, and when one transfers to a newer version of Thunderbird the settings should surely be the same?

But, you have not answers my question about whether this is caused by the Mac OSX or by Mozilla? As I have already said, I have used Thunderbird on PC's from 20 years ago and Mac's for the last 15 years and never had this issue before, and when one transfers to a newer version of Thunderbird the settings should surely be the same?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.