Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I change text colour?

more options

Hi helpful helpers,

When composing an email, if I select some text and click the text colour tool/icon, I see in the window "Choose a colour:" and a swatch. If I click the swatch, my colour picker pops up. I choose or make a colour, then...

How do I actually use that colour? How do I get it into the little Thunderbird text colour window? How do I apply it to my text? Am I doing something fundamentally stupid?

Many thanks, K.

Chosen solution

Sometimes the solutions do not work because the user has not set up the Preferences correctly and this effects any OS, Windows, MAC and Linx. Sometimes, the process does not work because unfortunately the user does not follow information correctly and exits the wrong window. But in your case, I'm not sure if you have correct preferences or whether the worng window was shut at wrong time or not.

Can you confirm you do not have anything that can override any choice you make:

  • Menu app icon > Preferences
  • Select 'General'
  • Scroll down to 'Language & Appearance' section
  • Click on 'Colours' button
  • Uncheck checkbox 'Use system colours'.
  • 'Override the colours specified by the content with my selection above': Select 'Never' from the drop down.
  • click on OK

Just so we understand your setup...Do you have that setting already or did you need to make any changes?

Once you have confirmed you have the settings as advised above... Test this in this order:

  1. in Formatting bar, click on the text colour square icon to open the 'TB colour picker'.
  2. click on 'Choose colour' to open the 'MAC color picker'
  3. Select the color with the 'Mac color picker'.
  4. Then close the 'Mac color picker' - this is important, so only the 'TB colour picker' is left open.
  5. Finally select OK in the 'TB color picker'.

Your feedback on using this very precise method is valuable.

Read this answer in context 👍 1

All Replies (9)

more options

Sorry! Should have said: Mac OS 10.14 Thunderbird 78.71

Helpful?

more options

The text color on Mac is explained here, followed by a video:

https://support.mozilla.org/en-US/questions/1276138#answer-1278599

Also, check your Color settings:

https://support.mozilla.org/en-US/questions/1319039

Helpful?

more options

Sorry :-( That didn't help - none of those things work for me.

It's obvious from that thread, tho, that I'm not alone in this issue so hopefully the issue will be addressed and fixed.

Many thanks, K

Helpful?

more options

You are not alone only if the information in thread fixed the issue (you need to close the mac colour picker window)

If it did not fix it for you, clearly your issue is something else. Sitting and waiting will achieve nothing but frustration for you as getting a "fix" in an update would be random chance really. It would require another user to present the issue, work to obtaining the steps for a developer to reproduce the problem. If the issue only affect you that will never happen, so it will never be fixed for you.

Modified by Matt

Helpful?

more options

Hi Matt, Several people in those threads say the solution doesn't work for them - not just me.

Your reply is quite agressive - I'm not "sitting waiting", I'm a very busy man. I will get around to helping out here on my terms when I feel like it.

Helpful?

more options

Chosen Solution

Sometimes the solutions do not work because the user has not set up the Preferences correctly and this effects any OS, Windows, MAC and Linx. Sometimes, the process does not work because unfortunately the user does not follow information correctly and exits the wrong window. But in your case, I'm not sure if you have correct preferences or whether the worng window was shut at wrong time or not.

Can you confirm you do not have anything that can override any choice you make:

  • Menu app icon > Preferences
  • Select 'General'
  • Scroll down to 'Language & Appearance' section
  • Click on 'Colours' button
  • Uncheck checkbox 'Use system colours'.
  • 'Override the colours specified by the content with my selection above': Select 'Never' from the drop down.
  • click on OK

Just so we understand your setup...Do you have that setting already or did you need to make any changes?

Once you have confirmed you have the settings as advised above... Test this in this order:

  1. in Formatting bar, click on the text colour square icon to open the 'TB colour picker'.
  2. click on 'Choose colour' to open the 'MAC color picker'
  3. Select the color with the 'Mac color picker'.
  4. Then close the 'Mac color picker' - this is important, so only the 'TB colour picker' is left open.
  5. Finally select OK in the 'TB color picker'.

Your feedback on using this very precise method is valuable.

Modified by Toad-Hall

Helpful?

more options

Hi Toad-Hall,

Yes - I checked the override when I read the thread sfhowes directed me to. It was already "Never" so I didn't change it.

> in Formatting bar, click on the text colour square icon to open the 'TB colour picker'. > click on 'Choose colour' to open the 'MAC color picker' > Select the color with the 'Mac color picker'. > Then close the 'Mac color picker' - this is important, so only the 'TB colour picker' is left open. > Finally select OK in the 'TB color picker'.

Yes - this has worked. I'm afraid that in my previous efforts, if I was told at some point to "close the 'Mac color picker'" I missed it.

Whilst this works and is a very easy solution, it seems odd and clumsy to have to close the colour picker. I don't think any other app works this way (I'm a designer and have used many apps where selecting colours is a normal activity).

Many thanks for your help. Kevin.

Helpful?

more options

Thanks for the feedback. I'm glad to hear it is now working for you. I have a Windows 10 OS. When I want to choose a colour, I have to : > in Formatting bar, click on the text colour square icon to open the 'TB colour picker'. > click on 'Choose colour' to open the 'Windows color picker' > Select the color with the 'Windows color picker'. > Then click on OK to close the Windows colour picker - I cannot even click or select the 'TB colour picker' until it is closed. So forced to click on the OK as this confirms the colour selection. > Finally select OK in the 'TB color picker'.

So, in effect I'm using the same process and it has always been that way. Hence it seems natural to me. Am I correct in thinking that the 'MAC colour picker' does not actually have an OK button which confirms colour selection and closes the window? If that's true then I can understand why it seems clunky and how easy it is to miss that important step.

Helpful?

more options

Jeebus! that sounds like a pain in the proberbials! I hope the TB developers are looking at this.

You're right - no OK button on the Mac OS colour picker: clicking a colour applies it. Some people, like me, run a little app that makes the colour picker even more persistent - it's basically on screen all the time. Closing a window I use so often is a bit of an alien concept. Several Mac OS "pickers" work this way; fonts and styling, character viewer/emoji picker, are examples. Mac OS users rarely "maximise" an app so it takes over the whole interface/screen, preferring instead to work in a window - this leaves us with easy access to the file manager, other apps and tools.

Thanks again for your help.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.