X
Tap here to go to the mobile version of the site.

Support Forum

Discover.com requires newer brouser

Posted

When I attempt to login to discover.com, it refuses to access my account and says that I need the latest version of my brouser. I am running ver. 71 of Firefox and it worked fine when I logged onto discover.com two weeks ago. Internet Explorer worked fine. Is this to be an ongoing problem or is it temporary?

When I attempt to login to discover.com, it refuses to access my account and says that I need the latest version of my brouser. I am running ver. 71 of Firefox and it worked fine when I logged onto discover.com two weeks ago. Internet Explorer worked fine. Is this to be an ongoing problem or is it temporary?

Chosen solution

Strangely enough, I made no changes to Firefox and the problem resolved itself. It must have been a problem on Discover's end and I jumped the gun instead of waiting several hours.

Thanks to all who replied.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

FredMcD
  • Top 10 Contributor
4340 solutions 61029 answers

Websites say that Firefox is outdated or incompatible even though it's the latest version https://support.mozilla.org/en-US/kb/websites-say-firefox-outdated-or-incompatible

This article is no longer maintained, so its content might be out of date.

Websites say that Firefox is outdated or incompatible even though it's the latest version https://support.mozilla.org/en-US/kb/websites-say-firefox-outdated-or-incompatible This article is no longer maintained, so its content might be out of date.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

It is possible that you have disabled some Firefox features that the website requires.

Are you possibly using Private Browsing mode or otherwise made changes to block content ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked

It is possible that you have disabled some Firefox features that the website requires. Are you possibly using Private Browsing mode or otherwise made changes to block content ? If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. *click the shield icon for more details and possibly disable the protection You can check in the Web Console what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop
Was this helpful to you?
Quote

Chosen Solution

Strangely enough, I made no changes to Firefox and the problem resolved itself. It must have been a problem on Discover's end and I jumped the gun instead of waiting several hours.

Thanks to all who replied.

Strangely enough, I made no changes to Firefox and the problem resolved itself. It must have been a problem on Discover's end and I jumped the gun instead of waiting several hours. Thanks to all who replied.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4340 solutions 61029 answers

Helpful Reply

Hopefully, it stays gone. Please flag your last post as Solved Problem as this can help others with similar problems.

Hopefully, it stays gone. Please flag your last post as '''Solved Problem''' as this can help others with similar problems.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

If this happens again then try some basic steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
If this happens again then try some basic steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.