Search Support

The website I visit is trusted but is http. Firefox keep changing it to https automaticly and then I get a 404 error of course. How do I prevent this change?

  • 9 replies
  • 4 have this problem
  • 136 views
  • Last reply by Frank

more options

http://rotterdam.rvc.nl/pandkaarten/search.asp I can reach with IE but firefox makes it https automaticly and the I get 404 - File or directory not found. I asked support from the site and they state it has to be http because no certificat. The site belongs to the city achrchive. I just found out there is no problem in the private window but I still liked it solved for the regular window.

Modified by Frank

Chosen solution

If you remove this rcv.nl line or rename/remove SiteSecurityServiceState.txt then Firefox should use the HTTP protocol to access this domain.

Read this answer in context 👍 1

All Replies (9)

more options

Hi Frank.

I can't reproduce this issue. It stays on http for me.

I'd check addons once more. Something like HTTPS Everywhere could trigger this redirect.

more options

Thanks for responding. I did try network.stricttransportsecurity.preloadlist and set it to false but that didn't help. Did try some other things I found trough google but most solutions offered were for servers redirecting. Adons I use Refresh & Monitor, Adblock Plus, NoScript

Changing security.tls.version.max to 2 and min to 0 didn't help either.

Modified by Frank

more options

Has something to do with that I use the portable version. \ I open it through a shortcut ( :\Firefox\FirefoxPortable\FirefoxPortable.exe ). When I open another instance through right click the Icon on the taskbar then ( E:\Firefox\FirefoxPortable\App\Firefox ) opens. With that there is no changing to https. But that one writes all kind of stuff to my C: partition.

Modified by Frank

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Thanks cor-el for responding. I did try that too and it didn't take the issue away. I hadn't this problem until a few months ago. I did search the net quite well and it seems nobody else mentioned the problem. So since using the private window works allright I think I leave it as it is. Should I mark this question as solved then?

Modified by Frank

more options

Did you check the SiteSecurityServiceState.txt file for references to this domain ?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Can you list your extensions?

more options

Adons I use Refresh & Monitor, Adblock Plus, NoScript.

SiteSecurityServiceState.txt sais:

rvc.nl:HSTS 5 18227 1635510555021,1,1,2

Don't know what that means.

I have to go now so I look to it further tomorrow.

more options

Chosen Solution

If you remove this rcv.nl line or rename/remove SiteSecurityServiceState.txt then Firefox should use the HTTP protocol to access this domain.

more options

cor-el,

As I said when I open firefox through that taskbar icon it writes to my C: partition and there are two profile files now. Neither of those contained rvc.nl:HSTS line so I thought your tip might work. Well I removed that line and saved it to a txt file restarted the computer and went to the rvc.nl site. And again it changed to https. The rvc.nl:HSTS line was back in the txt file. But I noticed a difference rvc.nl:HSTS 5 changed to 6, the rest of the line I have forgotten. So I removed that line again and thought lets do that forget this site again. Firefox got stuck with a script and after a while I decided to stop the script. Had to do that 3 times. And then presto! your solution worked.

Thank you verry much for your time and efforts.