X
Tap here to go to the mobile version of the site.

Support Forum

I want to get rid of the dropdown search bar permanently.

Posted

Remaking this thread because my old one (https://support.mozilla.org/en-US/questions/1249273#answer-1236713) was archived. The annoying dropdown bar when typing something in the URL thingie appears once more, and I want it to stop doing that.

In addition, with this newest update of Firefox I can no longer view images at imgur, as they're all black... and Netflix has also stopped functioning. Is there a way to fix this please? I don't really want to revert to an older version of Firefox but I'll do it if I must.

Thank you for reading.

Remaking this thread because my old one (https://support.mozilla.org/en-US/questions/1249273#answer-1236713) was archived. The annoying dropdown bar when typing something in the URL thingie appears once more, and I want it to stop doing that. In addition, with this newest update of Firefox I can no longer view images at imgur, as they're all black... and Netflix has also stopped functioning. Is there a way to fix this please? I don't really want to revert to an older version of Firefox but I'll do it if I must. Thank you for reading.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

jscher2000
  • Top 10 Contributor
8792 solutions 71910 answers

Helpful Reply

Hi Irrelevant, you can update your userChrome.css with this code to hide the new drop-down:

  /* Hide URL bar drop-down Fx70 */
  #urlbar .urlbarView {
    display: none !important;
  }

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi Irrelevant, you can update your userChrome.css with this code to hide the new drop-down: /* Hide URL bar drop-down Fx70 */ #urlbar .urlbarView { display: none !important; } ---- If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 2
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

What do you see if you right-click a black image?

Does that give you the image context menu (View Image, View image Info) ?

Can you see the images in "Tools -> Page Info -> Media" ?

What do you see if you right-click a black image? Does that give you the image context menu (View Image, View image Info) ? Can you see the images in "Tools -> Page Info -> Media" ?
Was this helpful to you?
Quote

Question owner

jscher2000 said

Hi Irrelevant, you can update your userChrome.css with this code to hide the new drop-down: /* Hide URL bar drop-down Fx70 */ #urlbar .urlbarView { display: none !important; }

EDIT: I initially fiddled with the wrong folder and made a new userChrome.css file. I triplechecked and found the correct one, and now this works - thank you! The dropdown menu has vanished.


jscher2000 said

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: How to clear the Firefox cache If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any improvement?

I tried disabling Ublock, privacy badger etc, as well as the new Firefox feature thing with the shield by the URL field - and clearing cookies and cache. Netflix still does not work. :(

Forgot to add - yes, I tried restarting Firefox in safe mode too, and Netflix is still not working. I am so confused.

''jscher2000 [[#answer-1261045|said]]'' <blockquote> Hi Irrelevant, you can update your userChrome.css with this code to hide the new drop-down: /* Hide URL bar drop-down Fx70 */ #urlbar .urlbarView { display: none !important; } </blockquote> EDIT: I initially fiddled with the wrong folder and made a new userChrome.css file. I triplechecked and found the correct one, and now this works - thank you! The dropdown menu has vanished. ---- ''jscher2000 [[#answer-1261045|said]]'' <blockquote> If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? </blockquote> I tried disabling Ublock, privacy badger etc, as well as the new Firefox feature thing with the shield by the URL field - and clearing cookies and cache. Netflix still does not work. :( Forgot to add - yes, I tried restarting Firefox in safe mode too, and Netflix is still not working. I am so confused.

Modified by Irrelevant

Was this helpful to you?
Quote

Question owner

cor-el said

What do you see if you right-click a black image? Does that give you the image context menu (View Image, View image Info) ? Can you see the images in "Tools -> Page Info -> Media" ?

I attached an image of what I see when I right-click a black image. It's in swedish, but no - I cannot view image or image info.

I can see some previews in the tools - page info - and media.

EDIT: I tried the advice from the post above, clearing the website cache and cookies - and now I can't even access the page! It's all dark grey. What on earth is happening?

''cor-el [[#answer-1261048|said]]'' <blockquote> What do you see if you right-click a black image? Does that give you the image context menu (View Image, View image Info) ? Can you see the images in "Tools -> Page Info -> Media" ? </blockquote> I attached an image of what I see when I right-click a black image. It's in swedish, but no - I cannot view image or image info. I can see some previews in the tools - page info - and media. EDIT: I tried the advice from the post above, clearing the website cache and cookies - and now I can't even access the page! It's all dark grey. What on earth is happening?

Modified by Irrelevant

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71910 answers

Helpful Reply

Hi Irrelevant, do you notice a difference between regular windows and private windows on problem sites?

Hi Irrelevant, do you notice a difference between regular windows and private windows on problem sites?
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

Hi Irrelevant, do you notice a difference between regular windows and private windows on problem sites?

Yes! I can access imgur and browse the images without problems in private browsing. How peculiar.

Netflix does work a little better, but I still cannot view movies. Error F7701-1003.

''jscher2000 [[#answer-1261068|said]]'' <blockquote> Hi Irrelevant, do you notice a difference between regular windows and private windows on problem sites? </blockquote> Yes! I can access imgur and browse the images without problems in private browsing. How peculiar. Netflix does work a little better, but I still cannot view movies. Error F7701-1003.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71910 answers

I think there is some privacy-related setting causing this problem, which is applicable in regular windows but not private windows. But off the top of my head, I don't know what it is.

I think there is some privacy-related setting causing this problem, which is applicable in regular windows but not private windows. But off the top of my head, I don't know what it is.
Was this helpful to you?
Quote

Question owner

jscher2000 said

I think there is some privacy-related setting causing this problem, which is applicable in regular windows but not private windows. But off the top of my head, I don't know what it is.

Please get back to me when/if you find out - thank you. :D

''jscher2000 [[#answer-1261095|said]]'' <blockquote> I think there is some privacy-related setting causing this problem, which is applicable in regular windows but not private windows. But off the top of my head, I don't know what it is. </blockquote> Please get back to me when/if you find out - thank you. :D
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

Any relevant messages in the Web Console?

  • "3-bar" menu button or Tools -> Web Developer

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Any relevant messages in the Web Console? *"3-bar" menu button or Tools -> Web Developer ----- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you?
Quote

Question owner

cor-el said

Any relevant messages in the Web Console?
  • "3-bar" menu button or Tools -> Web Developer

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

I'm sorry but this sounds like swahili to me? You want me to tell Firefox to forget about Netflix to see if that will help, is that what you are trying to tell me? :P

''cor-el [[#answer-1261100|said]]'' <blockquote> Any relevant messages in the Web Console? *"3-bar" menu button or Tools -> Web Developer ----- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox </blockquote> I'm sorry but this sounds like swahili to me? You want me to tell Firefox to forget about Netflix to see if that will help, is that what you are trying to tell me? :P

Modified by Irrelevant

Was this helpful to you?
Quote

Question owner

Well this just keeps getting better. I tried deleting aaaaall of the cookies, and now I cannot sign into my Youtube account because the "next" button when entering my email does not work.

Looks like I will have to revert to an old, functional Firefox version after all. This version blows.

EDIT: It won't let me use my regular profile with the older Firefox... is there a workaround for this at least? I just want to be able to use my internet browser. That should not be too much to ask.

Well this just keeps getting better. I tried deleting aaaaall of the cookies, and now I cannot sign into my Youtube account because the "next" button when entering my email does not work. Looks like I will have to revert to an old, functional Firefox version after all. This version blows. EDIT: It won't let me use my regular profile with the older Firefox... is there a workaround for this at least? I just want to be able to use my internet browser. That should not be too much to ask.

Modified by Irrelevant

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71910 answers

Irrelevant said

Well this just keeps getting better. I tried deleting aaaaall of the cookies, and now I cannot sign into my Youtube account because the "next" button when entering my email does not work.

It seems people affected by this problem cannot save cookies in regular windows, so lots of sites will not work.

EDIT: It won't let me use my regular profile with the older Firefox... is there a workaround for this at least? I just want to be able to use my internet browser. That should not be too much to ask.

There is a command-line parameter workaround to "downgrade" a profile to an older version: Dedicated profiles per Firefox installation

''Irrelevant [[#answer-1261162|said]]'' <blockquote> Well this just keeps getting better. I tried deleting aaaaall of the cookies, and now I cannot sign into my Youtube account because the "next" button when entering my email does not work. </blockquote> It seems people affected by this problem cannot save cookies in regular windows, so lots of sites will not work. <blockquote> EDIT: It won't let me use my regular profile with the older Firefox... is there a workaround for this at least? I just want to be able to use my internet browser. That should not be too much to ask. </blockquote> There is a command-line parameter workaround to "downgrade" a profile to an older version: [[Dedicated profiles per Firefox installation]]
Was this helpful to you? 1
Quote

Question owner

Thank you... so I add --allow-downgrade to the Firefox shortcut? I don't understand the guide at all. It tells me to press shift+F2 to access the whatever, but nothing happens when I press these two keys.

EDIT: Downgrade successful! I installed a functional version of Firefox, went to its folder and right-clicked the executable, and send to desktop as a shortcut. I then right-clicked this shortcut, added "--allow-downgrade" (without quotes) in the target field - and success! I can now use my browser again.

Thank you once more, jscher - you reckon they will fix this bug in a future update?

Thank you... so I add --allow-downgrade to the Firefox shortcut? I don't understand the guide at all. It tells me to press shift+F2 to access the whatever, but nothing happens when I press these two keys. EDIT: Downgrade successful! I installed a functional version of Firefox, went to its folder and right-clicked the executable, and send to desktop as a shortcut. I then right-clicked this shortcut, added "--allow-downgrade" (without quotes) in the target field - and success! I can now use my browser again. Thank you once more, jscher - you reckon they will fix this bug in a future update?

Modified by Irrelevant

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71910 answers

Firefox 70 users with this problem are being asked to check the results of the following diagnostic -- whether storage is reported as working or cannot be read:

https://firefox-storage-test.glitch.me/

I don't know whether it would be useful to test that on an older version, but if there is a problem, let me know.

Firefox 70 users with this problem are being asked to check the results of the following diagnostic -- whether storage is reported as working or cannot be read: https://firefox-storage-test.glitch.me/ I don't know whether it would be useful to test that on an older version, but if there is a problem, let me know.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.