X
Tap here to go to the mobile version of the site.

Support Forum

I've reinstalled windows 10 and firefox. Been trying for days to get new Top Sites to start showing up again. Top sites Check Box is ON

Posted

No Top sites when I go to HOME page, No Top sites OR Home Page when I open new tab. (Just a blank page), Top sites check box is 'ON', This is a fresh windows 10 install, Latest Firefox version is installed and has been running for several days now. It shouldn't be this hard to get top sites working again. It has to be something simple preventing all top sites from being displayed.

No Top sites when I go to HOME page, No Top sites OR Home Page when I open new tab. (Just a blank page), Top sites check box is 'ON', This is a fresh windows 10 install, Latest Firefox version is installed and has been running for several days now. It shouldn't be this hard to get top sites working again. It has to be something simple preventing all top sites from being displayed.
Attached screenshots

Modified by cnlmgmt1

Chosen solution

Is the Firefox Home page completely blank or do you at least have the cogwheel button in the top right corner to access the "Options/Preferences -> Home" page ?

You can check this pref on the about:config page to make sure the new tab page is enabled.

  • browser.newtabpage.enabled = true

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Open H264 Video Codec Widevine Content Decryption

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Helpful Reply

Hi cnlmgmt1, your fonts are a little bit odd-sized there. Possibly due to choosing a "Minimum" font size larger than 10?

Are you able to add a site to Top Sites manually? By that I mean, click the ••• icon all the way to the right of Top Sites, then click Add Top Site, and enter anything you like (with an http:// or https:// address). Will Firefox save and display it?

Is Firefox storing history normally? You can call up the Library window using either

  • Ctrl+Shift+h
  • menu > Library > History > Show All History

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi cnlmgmt1, your fonts are a little bit odd-sized there. Possibly due to choosing a "Minimum" font size larger than 10? Are you able to add a site to Top Sites manually? By that I mean, click the ••• icon all the way to the right of Top Sites, then click Add Top Site, and enter anything you like (with an http:// or https:// address). Will Firefox save and display it? Is Firefox storing history normally? You can call up the Library window using either * Ctrl+Shift+h * menu > Library > History > Show All History ---- Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158557 answers

Chosen Solution

Is the Firefox Home page completely blank or do you at least have the cogwheel button in the top right corner to access the "Options/Preferences -> Home" page ?

You can check this pref on the about:config page to make sure the new tab page is enabled.

  • browser.newtabpage.enabled = true

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Is the Firefox Home page completely blank or do you at least have the cogwheel button in the top right corner to access the "Options/Preferences -> Home" page ? You can check this pref on the <b>about:config</b> page to make sure the new tab page is enabled. *browser.newtabpage.enabled = true ---- Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Modified by cor-el

Was this helpful to you? 1
Quote

Question owner

Jscher2000 & Cor-el,

Sincere thanks for responding.

Jscher2000: "click the ••• icon all the way to the right of Top Sites"

Q: Specifically what page should I be seeing the *** icon? There's nothing on my browser home page (DuckduckGo nor Google) and I don't see any *** next to about:preferences#home / Firefox Home Content/ Top Sites.

Yes. I do have font size increased (Ease of Access\Display\Make Text Bigger)

Yes, plenty of websites are accumulating in my Firefox history (show all history)


safe mode-----

about:addons page says the following: "All add-ons have been disabled by safe mode."  :)

Observations at my google.com firefox home page: - No three dots *** - No trace of anything that would resemble "top sites" below the google search field where Top Sites normally live. - Looks like a standard everyday google search home page. - Firefox setting: "Zoom" is at 100%

Jscher2000 & Cor-el, Sincere thanks for responding. '''Jscher2000: "click the ••• icon all the way to the right of Top Sites"''' Q: Specifically what page should I be seeing the *** icon? There's nothing on my browser home page (DuckduckGo nor Google) and I don't see any *** next to about:preferences#home / Firefox Home Content/ Top Sites. Yes. I do have font size increased (Ease of Access\Display\Make Text Bigger) Yes, plenty of websites are accumulating in my Firefox history (show all history) ----safe mode----- about:addons page says the following: "All add-ons have been disabled by safe mode." :) Observations at my google.com firefox home page: - No three dots *** - No trace of anything that would resemble "top sites" below the google search field where Top Sites normally live. - Looks like a standard everyday google search home page. - Firefox setting: "Zoom" is at 100%

Modified by cnlmgmt1

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

cnlmgmt1 said

Q: Specifically what page should I be seeing the *** icon?

When hovering your mouse over the Top Sites section. Screenshot attached for reference.

''cnlmgmt1 [[#answer-1254525|said]]'' <blockquote> Q: Specifically what page should I be seeing the *** icon? </blockquote> When hovering your mouse over the Top Sites section. Screenshot attached for reference.
Was this helpful to you? 1
Quote

Question owner

Ahhh!! That entire Top Sites section under the search field in your picture doesn't exist for me!!


UPDATE: For Cor-El Browser newtabpage was set to false. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! B I N G O !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :) :) :) :)


Q: Any idea why it was 'false'  ??

Ahhh!! That entire Top Sites section under the search field in your picture doesn't exist for me!! '''UPDATE: For Cor-El''' Browser newtabpage was set to '''false'''. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! B I N G O !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :) :) :) :) Q: Any idea why it was 'false' ??

Modified by cnlmgmt1

Was this helpful to you?
Quote

Question owner

Thank you guys!!! Sincerely!!

Thank you guys!!! Sincerely!!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

cnlmgmt1 said

UPDATE: For Cor-El Browser newtabpage was set to false. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! B I N G O !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :) :) :) :)

Q: Any idea why it was 'false'  ??

False corresponds to selecting "Blank Page" under Options, Home (see attached screenshot). However, occasionally the Options page shows the wrong value and you may need to "turn it off and on again". Or go directly to about:config.

As for "why", no, possibly an add-on or external configuration file??

''cnlmgmt1 [[#answer-1254531|said]]'' <blockquote> '''UPDATE: For Cor-El''' Browser newtabpage was set to '''false'''. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! B I N G O !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :) :) :) :) <br><br> Q: Any idea why it was 'false' ?? </blockquote> False corresponds to selecting "Blank Page" under Options, Home (see attached screenshot). However, occasionally the Options page shows the wrong value and you may need to "turn it off and on again". Or go directly to about:config. As for "why", no, possibly an add-on or external configuration file??
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

cnlmgmt1 said
UPDATE: For Cor-El Browser newtabpage was set to false. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! B I N G O !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :) :) :) :)

Q: Any idea why it was 'false'  ??

False corresponds to selecting "Blank Page" under Options, Home (see attached screenshot). However, occasionally the Options page shows the wrong value and you may need to "turn it off and on again". Or go directly to about:config.

As for "why", no, possibly an add-on or external configuration file??

Excellent point!!! Thank you so much for all your help!!!

''jscher2000 [[#answer-1254662|said]]'' <blockquote> ''cnlmgmt1 [[#answer-1254531|said]]'' <blockquote> '''UPDATE: For Cor-El''' Browser newtabpage was set to '''false'''. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! B I N G O !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :) :) :) :) <br><br> Q: Any idea why it was 'false' ?? </blockquote> False corresponds to selecting "Blank Page" under Options, Home (see attached screenshot). However, occasionally the Options page shows the wrong value and you may need to "turn it off and on again". Or go directly to about:config. As for "why", no, possibly an add-on or external configuration file?? </blockquote> Excellent point!!! Thank you so much for all your help!!!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.