X
Tap here to go to the mobile version of the site.

Support Forum

I'm an old pro at creating desktop shortcuts on Firefox, but very recently - most come across with the standard Firefox Icon no matter the site. Can't find help

Posted

I've spent days looking at any help topics I can find, add ons, extensions, all the settings on my pc, but can find no joy, the websites work - but I need the Icon other than the Firefox Icon pic. Some come across ok. This has been happening for about 3 weeks.

I've spent days looking at any help topics I can find, add ons, extensions, all the settings on my pc, but can find no joy, the websites work - but I need the Icon other than the Firefox Icon pic. Some come across ok. This has been happening for about 3 weeks.

Chosen solution

Interesting. The Chase.com/login is a bad link. I went to https://secure07c.chase.com/web/auth/dashboard#/dashboard/overviewAccounts/overview/index and was able to create a drag-and-drop desktop shortcut.

Read this answer in context 1
Quote
Q041 0 solutions 9 answers

You can change this from Properties.

You can change this from Properties.
Was this helpful to you?
Quote

Question owner

Not wanting to choose one of the canned icons for a site; wanting the designated icon for the website to appear on the shortcut— just as it’s always done

Not wanting to choose one of the canned icons for a site; wanting the designated icon for the website to appear on the shortcut— just as it’s always done
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

Hello Spirit2go, Are you using a drag-and-drop method when you get those FF icons? There is an issue with that method associated with UAC. Take a look at this article, if you missed it, Drag and Drop Errors - How to Fix.

Hello Spirit2go, Are you using a drag-and-drop method when you get those FF icons? There is an issue with that method associated with UAC. Take a look at this article, if you missed it, [https://support.mozilla.org/en-US/kb/windows-administrator-launcher-process-error-fix Drag and Drop Errors - How to Fix].
Was this helpful to you?
Quote
Q041 0 solutions 9 answers

I'm sorry then, I don't remember Firefox doing that at all.

I'm sorry then, I don't remember Firefox doing that at all.
Was this helpful to you?
Quote

Question owner

Slipping the Cheese; thanks so much, the article def outlines the problem I'm having. UAC was disabled, but the Launcher Process says "disabled due to failure". I located the launcher.exe in a file and deleted that and fully enabled UAC again - still won't work. I tried the copy & past of the URL onto the desktop for a shortcut, still same problem..

Slipping the Cheese; thanks so much, the article def outlines the problem I'm having. UAC was disabled, but the Launcher Process says "disabled due to failure". I located the launcher.exe in a file and deleted that and fully enabled UAC again - still won't work. I tried the copy & past of the URL onto the desktop for a shortcut, still same problem..
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

If the launcher.exe file is still in your Recycle Bin, restore it. The Launcher Process for Firefox is written into the Firefox executable.

Type about:support in the address bar, press enter, and check to see if Launcher Process is Disabled Due To Failure.

If so, type about:config in the address bar, press enter and select "I Accept The Risk." Type launcher in the search bar at the top. The list will automatically populate to one entry - browser.launcherprocess.enabled - double-click it to toggle it to False, then, double-click it again back to True.

Restart Firefox.

Try creating a shortcut again.

If the launcher.exe file is still in your Recycle Bin, restore it. The Launcher Process for Firefox is written into the Firefox executable. Type '''about:support''' in the address bar, press enter, and check to see if Launcher Process is Disabled Due To Failure. If so, type '''about:config''' in the address bar, press enter and select "I Accept The Risk." Type '''launcher''' in the search bar at the top. The list will automatically populate to one entry - browser.launcherprocess.enabled - double-click it to toggle it to False, then, double-click it again back to True. Restart Firefox. Try creating a shortcut again.
Was this helpful to you?
Quote

Question owner

although launcher.exe was no longer in recycle bin - I followed your other instructions - toggling launcher process from false to true - tried another shortcut - still not working. Have I royally screwed up by deleting launcher.exe?

although launcher.exe was no longer in recycle bin - I followed your other instructions - toggling launcher process from false to true - tried another shortcut - still not working. Have I royally screwed up by deleting launcher.exe?
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

You didn't "royally screw up" Firefox but, I can't tell you what launcher.exe belongs to. I don't have it anywhere on my Win10.

After you toggled launcherprocess, did you close Firefox and open it again? Just checking.

You didn't "royally screw up" Firefox but, I can't tell you what launcher.exe belongs to. I don't have it anywhere on my Win10. After you toggled launcherprocess, did you close Firefox and open it again? Just checking.
Was this helpful to you?
Quote

Question owner

I reinstalled Firefox to see if launcher.exe came back but it didn't. Yes, after I followed your instructions, the launcher process said 'enabled', I went to about:config and toggled true/false. I then restarted Firefox and tried a shortcut -

I reinstalled Firefox to see if launcher.exe came back but it didn't. Yes, after I followed your instructions, the launcher process said 'enabled', I went to about:config and toggled true/false. I then restarted Firefox and tried a shortcut -
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

Firefox has a built-in Safe Mode. Let's check that none of your extensions are effecting this operation.

Click the Menu button. Go near the bottom and select Help. Select Restart With Add-ons Disabled. A dialog will appear, select Restart. Firefox will close and another dialog will appear. Select Restart In Safe Mode. (Not Refresh)

After Firefox opens try to drag-and drop a desktop shortcut.

Firefox has a built-in Safe Mode. Let's check that none of your extensions are effecting this operation. Click the Menu button. Go near the bottom and select Help. Select Restart With Add-ons Disabled. A dialog will appear, select Restart. Firefox will close and another dialog will appear. Select Restart In Safe Mode. (Not Refresh) After Firefox opens try to drag-and drop a desktop shortcut.
Was this helpful to you?
Quote

Question owner

Good to know about this Safemode option in Firefox, but it did not work to change shortcut - still came over as the website but with the Firefox "Fox" icon pic.

Good to know about this Safemode option in Firefox, but it did not work to change shortcut - still came over as the website but with the Firefox "Fox" icon pic.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

Which website did you visit? Let me try to duplicate the problem.

Which website did you visit? Let me try to duplicate the problem.
Was this helpful to you?
Quote

Question owner

Thank you...

I've been trying several, but as an example:

saltandserenity.com is one that comes over , also Chase.com

Thank you... I've been trying several, but as an example: saltandserenity.com is one that comes over , also Chase.com
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

Chase works fine. The Salt & Serenity site didn't. However, I did not see any type of logo. Only a huge header with the sites name. There is no favicon on the History, either. This seems to be a site specific issue.

Chase works fine. The Salt & Serenity site didn't. However, I did not see any type of logo. Only a huge header with the sites name. There is no favicon on the History, either. This seems to be a site specific issue.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

As far as Chase is concerned, and other sites as well, trying the Verify Integrity tool might help. Type about:support in the address bar. Scroll down to Places Database. (It's near the bottom.) Click the Verify Integrity button. Try Chase again.

As far as Chase is concerned, and other sites as well, trying the Verify Integrity tool might help. Type about:support in the address bar. Scroll down to Places Database. (It's near the bottom.) Click the Verify Integrity button. Try Chase again.
Was this helpful to you?
Quote

Question owner

so, I scrolled down to Places Database and clicked 'Verify Integrity' button. a list of things came up there. then went out to chase website and did a drag & drop. Still no good. was there another step after clicking on verify integrity button?

so, I scrolled down to Places Database and clicked 'Verify Integrity' button. a list of things came up there. then went out to chase website and did a drag & drop. Still no good. was there another step after clicking on verify integrity button?
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
85 solutions 887 answers

No other steps as far as I know.

I've run out of fixzits but, leave this thread open. A moderator should review it soon. Maybe they have a trick up their sleeve or something that I overlooked.

Tip: Do Not do a Refresh. Honestly, it causes more headaches than it's worth. It's a Last Resort option.

No other steps as far as I know. I've run out of fixzits but, leave this thread open. A moderator should review it soon. Maybe they have a trick up their sleeve or something that I overlooked. Tip: Do Not do a Refresh. Honestly, it causes more headaches than it's worth. It's a Last Resort option.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

Hello Spirit2go,

Stab in the dark, but maybe clearing the icons cache might work (?) :

https://neosmart.net/wiki/clear-icons-cache/#How_to_clear_the_icons_cache_in_Windows10

Also see :

https://windowsreport.com/fix-corrupted-desktop-icons-windows-10/

Hello Spirit2go, Stab in the dark, but maybe clearing the icons cache might work (?) : https://neosmart.net/wiki/clear-icons-cache/#How_to_clear_the_icons_cache_in_Windows10 Also see : https://windowsreport.com/fix-corrupted-desktop-icons-windows-10/
Was this helpful to you?
Quote

Question owner

thanks for trying... I will leave it open. I did think of Refresh, but decided against.

will review advice from McCoy and post anything useful

thanks for trying... I will leave it open. I did think of Refresh, but decided against. will review advice from McCoy and post anything useful
Was this helpful to you?
Quote

Question owner

Was able to delete Icon_Cache, restarted computer. Firefox icon still coming up randomly. For instance with Chase.com - the true icon comes up for that, but if I want to create a shortcut for Chase.com/login - to reach my personal account by dragging and dropping that URL- the firefox icon comes up. I will leave this open just in case, but for the moment - just going to have to suck it up and stop being frustrated by this issue. Thanks everyone

Was able to delete Icon_Cache, restarted computer. Firefox icon still coming up randomly. For instance with Chase.com - the true icon comes up for that, but if I want to create a shortcut for Chase.com/login - to reach my personal account by dragging and dropping that URL- the firefox icon comes up. I will leave this open just in case, but for the moment - just going to have to suck it up and stop being frustrated by this issue. Thanks everyone
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.