Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't apply for jobs on using Firefox, but this works on other browsers. A pop-up should appear when 'apply with indeed' is clicked at

  • 3 replies
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options
e.g.,iaBackPress,iaBackPress,iaBackPress,iaBackPress,iaBackPress&jk=defb3abf4f1e7661&l=Cambridge&q=product%20manager&rgtk=1dicuonsv3d26804&tk=1dicuonsv3d26804&utm_campaign=job_alerts&utm_medium=email&utm_source=jobseeker_emails is a problem page. I have pop-ups allowed for all sites, and I have unticked to allow all other content.

All Replies (3)

more options
more options

I had no problem with the link you posted. Try starting using Is the problem still there?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked