X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 68.0 screen upside down after update!

Posted

I updated Firefox to 68.0 on my PC, and now the browser is displayed upside down! All the graphics, tabs, icons, text etc are upside down, but NOT the functional buttons. That is, if I want to click on the menu button, I still have to click in the upper right corner, even though the menu button is shown upside down in the lower right corner. This is really annoying, and a real pain trying to navigate. How do I fix this? Or maybe I should downgrade to the previous version?

(It's not a Windows issue since the OS and all other programs are displayed as they should.)

I updated Firefox to 68.0 on my PC, and now the browser is displayed upside down! All the graphics, tabs, icons, text etc are upside down, but NOT the functional buttons. That is, if I want to click on the menu button, I still have to click in the upper right corner, even though the menu button is shown upside down in the lower right corner. This is really annoying, and a real pain trying to navigate. How do I fix this? Or maybe I should downgrade to the previous version? (It's not a Windows issue since the OS and all other programs are displayed as they should.)

Chosen solution

It could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:67.0) Gecko/67.0 Firefox/67.0

More Information

leetp4nd4 1 solutions 7 answers

I think someone wanted to make fun of you, so it was a joke:) But don't worry! I found the describtion how to do this(if you will need this in future who knows) or you can do this vice versa to return :

You can try to use Style sheet Style sheet can be downloaded at this address=> https://github.com/wesbos/aprilFools.css/blob/master/aprilFools.css. It was created for use in the Google Chrome browser, but it can also be used in Firefox and Opera, although you will need to make some changes, the description of which you will find a little below.

The file contains not only the possibility of turning the pages upside down, but also other funny tricks. You only need to find in the text the name of the desired effect and allow its application. This is done as follows:

1. Open the downloaded file aprilFools.css in any text editor.

2. Find the name of the desired effect in the text, for example upside down (upside down).

3. Uncomment it, that is, remove the / / signs.

So you had / * Turn every website upside down

  • /

body { / * - webkit-transform: rotate (180deg); * / }

Should be: / * Turn every website upside down

  • /

body { -webkit-transform: rotate (180deg); }

This browser does not support special styles out of the box, but you can use the Stylish(https://addons.mozilla.org/en-US/firefox/addon/stylish/) extension. Just install this extension and create a new style in which you copy the contents of the downloaded file. Just before that, remove all references to “-webkit-” in general. Thus, from -webkit-transform: rotate (180deg); you will just transform: rotate (180deg); .

I think someone wanted to make fun of you, so it was a joke:) But don't worry! I found the describtion how to do this(if you will need this in future who knows) or you can do this vice versa to return : You can try to use Style sheet Style sheet can be downloaded at this address=> https://github.com/wesbos/aprilFools.css/blob/master/aprilFools.css. It was created for use in the Google Chrome browser, but it can also be used in Firefox and Opera, although you will need to make some changes, the description of which you will find a little below. The file contains not only the possibility of turning the pages upside down, but also other funny tricks. You only need to find in the text the name of the desired effect and allow its application. This is done as follows: 1. Open the downloaded file aprilFools.css in any text editor. 2. Find the name of the desired effect in the text, for example upside down (upside down). 3. Uncomment it, that is, remove the / / signs. So you had / * Turn every website upside down * / body { / * - webkit-transform: rotate (180deg); * / } Should be: / * Turn every website upside down * / body { -webkit-transform: rotate (180deg); } This browser does not support special styles out of the box, but you can use the Stylish(https://addons.mozilla.org/en-US/firefox/addon/stylish/) extension. Just install this extension and create a new style in which you copy the contents of the downloaded file. Just before that, remove all references to “-webkit-” in general. Thus, from -webkit-transform: rotate (180deg); you will just transform: rotate (180deg); .
Was this helpful to you?
Quote

Question owner

Wait... I haven't visited any special website, and I haven't downloaded a single file. What I did was using Firefox' own update service yesterday, before I shut down the computer. And when I started it today Firefox displays everything upside down. Where would the css file come from in that case?

Wait... I haven't visited any special website, and I haven't downloaded a single file. What I did was using Firefox' own update service yesterday, before I shut down the computer. And when I started it today Firefox displays everything upside down. Where would the css file come from in that case?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157357 answers

Can you attach a screenshot?

Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4225 solutions 58977 answers

What's your computer system and Firefox version?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

What's your computer system and Firefox version? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote

Question owner

I have Windows 10 Pro, Firefox Quantum 68.0. Computer is an AMD Ryzen 5 1600, ASUS motherboard, GeForce GTX 1050 Ti. Graphics drivers and Windows are up to date.

Tried to reinstall Firefox but the problem persist. Firefox safe mode rotates the browser as it should be, so I removed the two add-ons I used (NoScript and Social Fixer). But the upside down screen in normal mode still persist.

I have Windows 10 Pro, Firefox Quantum 68.0. Computer is an AMD Ryzen 5 1600, ASUS motherboard, GeForce GTX 1050 Ti. Graphics drivers and Windows are up to date. Tried to reinstall Firefox but the problem persist. Firefox safe mode rotates the browser as it should be, so I removed the two add-ons I used (NoScript and Social Fixer). But the upside down screen in normal mode still persist.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4225 solutions 58977 answers

Chosen Solution

It could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

It could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Was this helpful to you? 1
Quote

Question owner

Disabling Hardware Acceleration fixed the problem. Thanks!

Disabling Hardware Acceleration fixed the problem. Thanks!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4225 solutions 58977 answers

Glad to help. Safe Surfing. Very, very odd, however.

Glad to help. Safe Surfing. Very, very odd, however.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.