X
Tap here to go to the mobile version of the site.

Support Forum

No streaming services (Netflix, HBO Now, Prime Video) work with Firefox

Posted

Hello,

I am running Firefox 67.0.4. No video streaming services work with the browser. Each one gives me some sort of error message:

Netflix - Unexpected Error, F7111 HBO - Can't play video, please try again later Amazon Prime - Unsupported Browser

This has been occurring for almost two years now, during which time I have been using Chrome (yuck) to stream video.

I have a VPN installed on my computer (for work) but I am not connected to it, and these problems have been occurring since before I installed the VPN.

I am running the latest version of Flash and Widevine. I have Netflix set to play DRM content in my preferences (I have tried unchecking and checking that box and restarting Firefox). I am running uBlock Origin, Privacy Badger, and HTTPS Everywhere, but disabling any or all of the add-ons does not solve the issue.

I am going to try refreshing the program but am open to any suggestions before I do so.

Hello, I am running Firefox 67.0.4. No video streaming services work with the browser. Each one gives me some sort of error message: Netflix - Unexpected Error, F7111 HBO - Can't play video, please try again later Amazon Prime - Unsupported Browser This has been occurring for almost two years now, during which time I have been using Chrome (yuck) to stream video. I have a VPN installed on my computer (for work) but I am not connected to it, and these problems have been occurring since before I installed the VPN. I am running the latest version of Flash and Widevine. I have Netflix set to play DRM content in my preferences (I have tried unchecking and checking that box and restarting Firefox). I am running uBlock Origin, Privacy Badger, and HTTPS Everywhere, but disabling any or all of the add-ons does not solve the issue. I am going to try refreshing the program but am open to any suggestions before I do so.

Chosen solution

This last screenshot would suggest that Firefox gets an HTML error page (Content-Type text/html) for the requested media.

Do any server requests show if you enable XHR and Requests in the Console ? See also the Network Monitor (XHR, Media, Others).

You can check the media.mediasource prefs on the about:config page and reset any that appear user set (bold) via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

FredMcD
  • Top 10 Contributor
4188 solutions 58471 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection

https://support.mozilla.org/en-US/kb/content-blocking

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link} https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you?
Quote

Question owner

Hi Fred,

Thank you for your response. Unfortunately neither of these solutions fixed the issue.

I tried starting Firefox in safe mode, but I am still getting the same errors.

Also, there is no "tracking protection" shield icon at the left end of the address bar. There is only the green padlock and the grey chain-link indicating DRM content.

Please let me know if you have any other suggestions before I do a refresh.

Hi Fred, Thank you for your response. Unfortunately neither of these solutions fixed the issue. I tried starting Firefox in safe mode, but I am still getting the same errors. Also, there is no "tracking protection" shield icon at the left end of the address bar. There is only the green padlock and the grey chain-link indicating DRM content. Please let me know if you have any other suggestions before I do a refresh.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

Make sure that DRM is enabled and that the Widevine plugin is installed and enabled.

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

Make sure that DRM is enabled and that the Widevine plugin is installed and enabled. Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components. *Options/Preferences -> General: Play DRM *https://support.mozilla.org/en-US/kb/enable-drm
Was this helpful to you?
Quote

Question owner

Hi Cor-el, I addressed both of those possibilities in my post.

I have already toggled DRM on/off and restarted Firefox, many times. The Widevine plug-in is installed, enabled, and updated.

Hi Cor-el, I addressed both of those possibilities in my post. I have already toggled DRM on/off and restarted Firefox, many times. The Widevine plug-in is installed, enabled, and updated.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

Any luck on this website?

Any luck on this website? *https://shaka-player-demo.appspot.com/
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

This issue can be caused by corrupted cookies or cookies that are blocked.

  • check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions"

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode" This issue can be caused by corrupted cookies or cookies that are blocked. *check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions" You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote

Question owner

Hi Cor-el, thank you for these suggestions. The shaka-player-demo website you provided gave me the message that my browser is not supported.

I have checked my privacy and security setting and confirmed that Firefox is not set to always run in private browsing mode.

As for page permissions, I check and every box is set to "use default."

Reloading the webpages while bypassing the cache did not solve the issue.

I have cleared my entire cache and cookies many times while attempting to fix this issue, it has never worked.

Regarding the theme, I did have it set to Light, but I've changed it back to Default on your suggestion, and unfortunately it has not fixed the issue.

I have already started Firefox in safe mode, it had no effect on the issue.

Hi Cor-el, thank you for these suggestions. The shaka-player-demo website you provided gave me the message that my browser is not supported. I have checked my privacy and security setting and confirmed that Firefox is not set to always run in private browsing mode. As for page permissions, I check and every box is set to "use default." Reloading the webpages while bypassing the cache did not solve the issue. I have cleared my entire cache and cookies many times while attempting to fix this issue, it has never worked. Regarding the theme, I did have it set to Light, but I've changed it back to Default on your suggestion, and unfortunately it has not fixed the issue. I have already started Firefox in safe mode, it had no effect on the issue.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

Does the Web Console give more detail about what is wrong?

Does the Web Console give more detail about what is wrong? *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console
Was this helpful to you?
Quote

Question owner

I tried it on Netflix. It says "unreachable code after return statement" over and over again, in relation to something called cadmium-playercore. Here is the info from Firefox help pages:

https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Stmt_after_return?utm_source=mozilla&utm_medium=firefox-console-errors&utm_campaign=default

That's the only error or warning it gives.

I tried it on Netflix. It says "unreachable code after return statement" over and over again, in relation to something called cadmium-playercore. Here is the info from Firefox help pages: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Stmt_after_return?utm_source=mozilla&utm_medium=firefox-console-errors&utm_campaign=default That's the only error or warning it gives.
Was this helpful to you?
Quote

Question owner

I've attached a screenshot of the error messages for HBO Now.

I've attached a screenshot of the error messages for HBO Now.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4188 solutions 58471 answers

Try the 'Learn More' link. Anything there?

Try the 'Learn More' link. Anything there?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

Chosen Solution

This last screenshot would suggest that Firefox gets an HTML error page (Content-Type text/html) for the requested media.

Do any server requests show if you enable XHR and Requests in the Console ? See also the Network Monitor (XHR, Media, Others).

You can check the media.mediasource prefs on the about:config page and reset any that appear user set (bold) via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This last screenshot would suggest that Firefox gets an HTML error page (Content-Type text/html) for the requested media. Do any server requests show if you enable XHR and Requests in the Console ? See also the Network Monitor (XHR, Media, Others). *https://developer.mozilla.org/en-US/Tools/Network_Monitor You can check the <b>media.mediasource</b> prefs on the <b>about:config</b> page and reset any that appear user set (bold) via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

Does the YouTube test page show at least that you have proper support for playing media files via the HTML5 media player?

You can check for problems with preferences.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Does the YouTube test page show at least that you have proper support for playing media files via the HTML5 media player? *https://www.youtube.com/html5 You can check for problems with preferences. *delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases *http://kb.mozillazine.org/preferences_not_saved *http://kb.mozillazine.org/resetting_preferences You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox ---- You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
Was this helpful to you?
Quote

Question owner

Well, Cor-el, you fixed the issue.

Media.mediasource.enabled was set to false. I reset that, and now all the streaming services are working.

I'm not sure how that happened, as I've never been in the about:config before, but thank you very much. I really appreciate your help and patience.

Well, Cor-el, you fixed the issue. Media.mediasource.enabled was set to false. I reset that, and now all the streaming services are working. I'm not sure how that happened, as I've never been in the about:config before, but thank you very much. I really appreciate your help and patience.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

You're welcome. The screenshot you posted helped to identify a possible cause.

This should have happened a long time ago if you haven't been able to play these media files for two years. Maybe next time not to hesitate that long to ask for support :wink:

You're welcome. The screenshot you posted helped to identify a possible cause. This should have happened a long time ago if you haven't been able to play these media files for two years. Maybe next time not to hesitate that long to ask for support :wink:
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.