Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

load duckduckgo on firefox

  • 4 replies
  • 1 has this problem
  • 15 views
  • Last reply by McCoy

more options

I find it impossible to load any other search engine on my lap top which I am using as a desk top, which is using windows 10 operating system and operates google. Paul.

All Replies (4)

more options

Hello Paul,

Your system details show that you have this add-on installed :

"Search Encrypt - A Private Search Engine "

Even though it's listed on the addons.mozilla.org page - it's a browser hijacker. Even if you have installed this add-on yourself - it may be the cause of your problem.

Would you please follow these steps :

Go to the Firefox menu (≡) => Add-ons => Extensions and remove the add-on.

Next step is to run malwarescans - further information can be found in this article :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. They all work differently - what one program doesn't pick up, the other might.

Also see : https://malwaretips.com/blogs/remove-search-encrypt/

Hopefully you will now be able to install DuckDuckGo (or any other search engine of your choice).....

more options

There are also two inactive extensions showing that look suspicious:

Email 100.60 (web@Email) (Inactive)
Recipes 100.7 (web@Recipes) (Inactive)
more options

I have tried all you have suggested including downloading a malware program, which I have run, along with my normal Eset antivirus program. I have now got fed up, tired and am going for a nap and given up. I shall now put up with microsh*t with its ruddy google. Best wishes and thanks for trying to help me. BTW I'm nearly 78 and I've had a stroke! Paul.

more options

Dear Paul, I'm sorry to hear about your stroke - I sure hope that you're feeling better now.

Back to your problem: Google search engine has nothing to do with Microsoft - Microsoft's search engine is Bing .....

You say that you've tried everything that was suggested - I'm now thinking that "Search Encrypt" wasn't the problem here at all, but that you just need to be able to set your default search engine.

If you haven't already, would you please go to 3-bar menu => Options => Search, and choose the search engine you want to set as default. If it isn't listed under "One-Click Search Engines", then click on "Restore Default Search Engines" and DuckDuckGo should be there.

Also see : https://support.mozilla.org/en-US/kb/change-your-default-search-settings-firefox

If this still doesn't solve your problem : please, let us know.

(by the way : age is nothing but a number .... )