X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 67.0.1 Mac; search in google displays results then just redirects to bing search.

Posted

I've made sure that Google search is selected as default; AND Bing is not even listed anywhere (I've removed it from the list of search engines).

YET, typing a search term displays ".... search in Google", then displays Google's results, then just redirects to Bing for that search.

How do I stop Firefox from doing this?

I've made sure that Google search is selected as default; AND Bing is not even listed anywhere (I've removed it from the list of search engines). YET, typing a search term displays ".... search in Google", then displays Google's results, then just redirects to Bing for that search. How do I stop Firefox from doing this?
Quote
FredMcD
  • Top 10 Contributor
4148 solutions 57912 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Bing “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''(<Control> ''[Mac=<Command>]'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Remove “ Bing “ '''Anything. ''' Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch Now do the same in the computer’s '''Programs Folder. ''' '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the '''Applications''' folder. '''Linux:''' Check your user manual.
Was this helpful to you? 0
Quote

Question owner

FredMcD said

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A) In the Add-ons Manager, on the left, select Extensions. Remove “ Bing “ Anything.

Thanks, but there was NOTHING "bing" there.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Again, none of those were there either. Nothing "search" related at all. Just: anonymox, scdl soundcloud downloader, simpleyoutube to mp3/mp4 converter, video downloadhelper, and youtube best video downloader 2.

Now do the same in the computer’s Programs Folder.

And no apps like that either.

''FredMcD [[#answer-1228603|said]]'' <blockquote> Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''(<Control> ''[Mac=<Command>]'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Remove “ Bing “ '''Anything. '''</blockquote> Thanks, but there was NOTHING "bing" there. <blockquote>Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch</blockquote> Again, none of those were there either. Nothing "search" related at all. Just: anonymox, scdl soundcloud downloader, simpleyoutube to mp3/mp4 converter, video downloadhelper, and youtube best video downloader 2. <blockquote>Now do the same in the computer’s '''Programs Folder. ''' </blockquote> And no apps like that either.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4148 solutions 57912 answers

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote

Question owner

FredMcD said

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Thanks. Started in safe mode and the problem did NOT show up. Any guess on what disabled add-on might have caused this?

''FredMcD [[#answer-1228656|said]]'' <blockquote> A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Thanks. Started in safe mode and the problem did NOT show up. Any guess on what disabled add-on might have caused this?
Was this helpful to you?
Quote

Question owner

FredMcD said

Start In Safe Mode (not Refresh).

The problem now is that when I restarted Firefox (no longer in safe mode) NONE of my settings, passwords, addons, etc. were restored!!!!!

That'll teach me to NEVER start in safe mode again!!!!

''FredMcD [[#answer-1228656|said]]'' <blockquote> '''Start In Safe Mode''' (not Refresh). </blockquote> The problem now is that when I restarted Firefox (no longer in safe mode) NONE of my settings, passwords, addons, etc. were restored!!!!! That'll teach me to NEVER start in safe mode again!!!!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4148 solutions 57912 answers

Safe Mode does not do that. It's possible Firefox did a reset.

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


Refreshing Firefox {web link} is a LAST RESORT ! !

Refreshing Firefox -- easily fix most problems

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. Note: Refresh saves your old profile to the desktop in a folder called Old Firefox.

Safe Mode does not do that. It's possible Firefox did a reset. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. --------------- [https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refreshing Firefox] {web link} is a '''LAST RESORT ! !''' Refreshing Firefox -- easily fix most problems If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. '''Note:''' Refresh saves your old profile to the desktop in a folder called '''Old Firefox.'''
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4148 solutions 57912 answers
Look on your desktop. Do you see a folder called; '''Old Firefox?''' Look inside. Look for the folder with the latest creation date. https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.