X
Tap here to go to the mobile version of the site.

Support Forum

GMail via Firefox insists on addressing me in German, which I don't spreak.

Posted

I have Google set to English (UK), the same for Microsoft and Firefox. Despite this (I live in Austria) GMail opens now in German, which I don't speak. I usually have to change languages twice!

It happened after a Firefox update a couple of months ago. I have no problems with Microsoft programmes.

When I open GMail, it is in German. I change the language to English UK, then I get offerred an English sign-in page. When I sign in however, we're back to German again

What other language settings are there that I can change?

I have Google set to English (UK), the same for Microsoft and Firefox. Despite this (I live in Austria) GMail opens now in German, which I don't speak. I usually have to change languages twice! It happened after a Firefox update a couple of months ago. I have no problems with Microsoft programmes. When I open GMail, it is in German. I change the language to English UK, then I get offerred an English sign-in page. When I sign in however, we're back to German again What other language settings are there that I can change?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

McCoy
  • Top 10 Contributor
468 solutions 4262 answers

Hello qorval,

My apologies if this is a rethorical question, but after you changed the language, did you then scroll all the way down and click the "Save Changes" button  ?

See :

Change your Gmail language settings

Hello qorval, My apologies if this is a rethorical question, but after you changed the language, did you then scroll all the way down and click the "Save Changes" button ? See : [https://support.google.com/mail/answer/17091?co=GENIE.Platform%3DDesktop&hl=en Change your Gmail language settings]
Was this helpful to you?
Quote

Question owner

Maybe there's a possible solution contained in your answer. In my Firefox I only see Firefox settings, in which my chosen language is English, and which did not require to be saved. There's no save button anyway

I can't see GMail settings at all, so I can't change languages (in the top right corner of anywhere else). And if I don't see the settings at all I can't change the GMail language.

Any idea where I can find GMail settings?

Maybe there's a possible solution contained in your answer. In my Firefox I only see Firefox settings, in which my chosen language is English, and which did not require to be saved. There's no save button anyway I can't see GMail settings at all, so I can't change languages (in the top right corner of anywhere else). And if I don't see the settings at all I can't change the GMail language. Any idea where I can find GMail settings?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
468 solutions 4262 answers

qorval said

Any idea where I can find GMail settings?

Sure : Open your Gmail account and click on the cogwheel (on the right side).

You'll get a dropdown and there you click on "Settings" ......

See : Change you Gmail settings

Does that help  ?

''qorval [[#answer-1223120|said]]'' <blockquote> Any idea where I can find GMail settings? </blockquote> Sure : Open your Gmail account and click on the cogwheel (on the right side). You'll get a dropdown and there you click on "Settings" ...... See : [https://support.google.com/mail/answer/6562?co=GENIE.Platform%3DDesktop&hl=en Change you Gmail settings] Does that help ?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
468 solutions 4262 answers
[https://www.google.nl/search?q=images+of+a+cogwheel&authuser=1&tbm=isch&source=iu&ictx=1&fir=cLdba0ApjDrmzM%253A%252C9kxUw5WsuxyNPM%252C_&vet=1&usg=AI4_-kSzXZ9n_UAC11C3heoNLXtAMK91Yw&sa=X&ved=2ahUKEwirzsaMmqXiAhWCEVAKHZoGCg0Q9QEwBXoECAkQDg#imgrc=cLdba0ApjDrmzM: In case you don't know what a cogwheel (aka : gear) looks like ......]
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17277 solutions 156165 answers

Could be a cookie problem. Did you alreaady cleared the Gmail (google) cookies?


Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Could be a cookie problem. Did you alreaady cleared the Gmail (google) cookies? ---- Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.