X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn’t know how to open this address, because one of the following protocols (javascript) isn’t associated with any program or is not allowed i

Posted

All of a sudden I can not open my "suspect email" folders on Earthlink webmail.

Clicking on the select box returns error message

The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (javascript) isn’t associated with any program or is not allowed in this context.

   You might need to install other software to open this address.


I'm having to run Chrome to do this. Bummer

All of a sudden I can not open my "suspect email" folders on Earthlink webmail. Clicking on the select box returns error message The address wasn’t understood Firefox doesn’t know how to open this address, because one of the following protocols (javascript) isn’t associated with any program or is not allowed in this context. You might need to install other software to open this address. I'm having to run Chrome to do this. Bummer

Chosen solution

You can check this pref on the about:config page and make sure it is default and not user set (bold).

  • network.protocol-handler.external.javascript = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 1
Quote
jscher2000
  • Top 10 Contributor
8507 solutions 69508 answers

That's strange. Does it seem that Earthlink has been making changes on its webmail site?

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

That's strange. Does it seem that Earthlink has been making changes on its webmail site? If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156121 answers

Chosen Solution

You can check this pref on the about:config page and make sure it is default and not user set (bold).

  • network.protocol-handler.external.javascript = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can check this pref on the <b>about:config</b> page and make sure it is default and not user set (bold). *network.protocol-handler.external.javascript = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config

Modified by cor-el

Was this helpful to you? 1
Quote

Question owner

That suggestion is all over the web and I did try it several times to no success. (network.protocol-handler.external.javascript = false)

Searching for the string never found that entry. Came up blank every time.

But YOUR solution seems to have worked! I found the string (!) and set if false.

And now it works the way it was supposed to. Maybe the spelling is a bit different here, or something?

Anyway... Thank you, thanks you, thank you all.

I ♥ Firefox and was really bummed out having to install Chrome. (ps: I started browsing with Netscape - ages ago)

Now, about that auto-update check? Five or six times a day??? Is there an option to turn that off??? Or should that question be another post?

That suggestion is all over the web and I did try it several times to no success. (network.protocol-handler.external.javascript = false) Searching for the string never found that entry. Came up blank every time. But YOUR solution seems to have worked! I found the string (!) and set if false. And now it works the way it was supposed to. Maybe the spelling is a bit different here, or something? Anyway... Thank you, thanks you, thank you all. I ♥ Firefox and was really bummed out having to install Chrome. (ps: I started browsing with Netscape - ages ago) Now, about that auto-update check? Five or six times a day??? Is there an option to turn that off??? Or should that question be another post?

Modified by cavelamb

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156121 answers

That is weird.

How/where did you previously looked for this pref that you didn't find it?

That is weird. How/where did you previously looked for this pref that you didn't find it?
Was this helpful to you?
Quote

Question owner

Google "Firefox doesn’t know how to open this address, because one of the following protocols (javascript) isn’t associated with any program or is not allowed in this context. "

Answers go back as far as 2012

Google "Firefox doesn’t know how to open this address, because one of the following protocols (javascript) isn’t associated with any program or is not allowed in this context. " Answers go back as far as 2012
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.